Re: [PATCH] Cannot wait for user lock in sync_while_locked

2012-03-13 Thread Keith Packard
<#part sign=pgpmime> On Sat, 10 Mar 2012 21:05:21 -0800, Jamey Sharp wrote: > Looks great; just insert "let the thread [that] got in first" and > push. :-) With a bit of additional testing (I rebooted my laptop...), I discovered that this second patch breaks gdm3 very badly, so I have not pushed

Re: [PATCH xorg-gtest v2 0/9] Switch from a precompiled library to a source distribution

2012-03-13 Thread Chase Douglas
On 03/13/2012 10:39 PM, Chase Douglas wrote: > On 03/13/2012 07:30 PM, Gaetan Nadon wrote: >> On 12-03-13 08:53 PM, Gaetan Nadon wrote: >>> On 12-03-13 02:47 PM, Chase Douglas wrote: The major change in this round is to patch 8. Instead of instructing users to include an automake sn

Re: [PATCH] include: add an X_DEBUG message type

2012-03-13 Thread Peter Hutterer
On Tue, Mar 13, 2012 at 10:41:25PM -0700, Jamey Sharp wrote: > The #ifndef in log.c looks wrong, but otherwise, sure, why not? With that > fixed: > > Reviewed-by: Jamey Sharp oops, amended, thanks. Cheers, Peter > On 3/13/12, Peter Hutterer wrote: > > Signed-off-by: Peter Hutterer > > --

[PATCH 9/9] Xext: Add per-device SyncCounters

2012-03-13 Thread Peter Hutterer
Previously, we only had one idle alarm that was triggered for all devices, whenever the user used any device, came back from suspend, etc. Add system SyncCounters for each device (named "DEVICEIDLETIME x", with x being the device id) that trigger on that device only. This allows for enabling/disab

[PATCH 8/9] Change lastDeviceIdleTime to be per-device

2012-03-13 Thread Peter Hutterer
Preparation work for per-device idle counters. Signed-off-by: Peter Hutterer --- Xext/saver.c |7 +-- Xext/sync.c|2 +- Xi/exevents.c |2 +- dix/events.c | 13 +++-- dix/globals.c |2 +- dix/window.c |4

[PATCH 7/9] Xext: strdup() the SystemSyncCounter name

2012-03-13 Thread Peter Hutterer
Required for future dynamic names. Signed-off-by: Peter Hutterer --- Xext/sync.c|3 ++- Xext/syncsrv.h |2 +- 2 files changed, 3 insertions(+), 2 deletions(-) diff --git a/Xext/sync.c b/Xext/sync.c index df0aa0d..81f20db 100644 --- a/Xext/sync.c +++ b/Xext/sync.c @@ -1011,7 +1011,7

[PATCH 6/9] Xext: store the bracket values for idle counters in the private

2012-03-13 Thread Peter Hutterer
And drop the three global variables, we have a reference to the counter everywhere now. Signed-off-by: Peter Hutterer --- Xext/sync.c | 45 ++--- 1 files changed, 26 insertions(+), 19 deletions(-) diff --git a/Xext/sync.c b/Xext/sync.c index 17e64e5..df

[PATCH 5/9] Xext: pass the counter into block/wakeup handlers

2012-03-13 Thread Peter Hutterer
No functional changes, currently unused. Preparation work, we don't need a global variable if we can pass the counters around anyway. Signed-off-by: Peter Hutterer --- Xext/sync.c |8 1 files changed, 4 insertions(+), 4 deletions(-) diff --git a/Xext/sync.c b/Xext/sync.c index a219

[PATCH 4/9] Xext: add a private field to SyncSystemCounters

2012-03-13 Thread Peter Hutterer
Will be used to store counter-specific data. Signed-off-by: Peter Hutterer --- Xext/sync.c|2 ++ Xext/syncsrv.h |3 +++ 2 files changed, 5 insertions(+), 0 deletions(-) diff --git a/Xext/sync.c b/Xext/sync.c index f07f6dd..a219809 100644 --- a/Xext/sync.c +++ b/Xext/sync.c @@ -1016,

[PATCH 3/9] Xext: localise pIdleTimeValueLess/Greater

2012-03-13 Thread Peter Hutterer
Cleanup for future features, no functional changes. Signed-off-by: Peter Hutterer --- Xext/sync.c | 29 - 1 files changed, 16 insertions(+), 13 deletions(-) diff --git a/Xext/sync.c b/Xext/sync.c index e97b124..f07f6dd 100644 --- a/Xext/sync.c +++ b/Xext/sync.c @@

[PATCH 2/9] Xext: localise use of IdleTimeCounter

2012-03-13 Thread Peter Hutterer
Instead of referring to the global IdleTimeCounter everywhere, only do it once and use a local variable for the rest. Cleanup for future features, no functional changes. Signed-off-by: Peter Hutterer --- Xext/sync.c | 16 +--- 1 files changed, 9 insertions(+), 7 deletions(-) diff

[PATCH 1/9] Xext: reset number of system counters on cleanup.

2012-03-13 Thread Peter Hutterer
Signed-off-by: Peter Hutterer --- Xext/sync.c |1 + 1 files changed, 1 insertions(+), 0 deletions(-) diff --git a/Xext/sync.c b/Xext/sync.c index 7791ab6..46b9cb8 100644 --- a/Xext/sync.c +++ b/Xext/sync.c @@ -2552,6 +2552,7 @@ SyncResetProc(ExtensionEntry *extEntry) { free(SysCounterL

[PATCH 0/9] per-device idle counters

2012-03-13 Thread Peter Hutterer
We currently have one global idlecounter. This patch series adds additional counters named "DEVICEIDLETIME n" (where n is the device id) that apply to that device only. One use-case here is as syndaemon replacement. A client can simply put an idlecounter on the keyboard above the touchpad. When

Re: [PATCH] include: add an X_DEBUG message type

2012-03-13 Thread Jamey Sharp
The #ifndef in log.c looks wrong, but otherwise, sure, why not? With that fixed: Reviewed-by: Jamey Sharp On 3/13/12, Peter Hutterer wrote: > Signed-off-by: Peter Hutterer > --- > Just a nice-to-have, makes grep a tad easier. > > include/os.h |1 + > os/log.c |5 + > 2 files c

Re: [PATCH xorg-gtest v2 0/9] Switch from a precompiled library to a source distribution

2012-03-13 Thread Chase Douglas
On 03/13/2012 07:30 PM, Gaetan Nadon wrote: > On 12-03-13 08:53 PM, Gaetan Nadon wrote: >> On 12-03-13 02:47 PM, Chase Douglas wrote: >>> The major change in this round is to patch 8. Instead of instructing users >>> to >>> include an automake snippet installed on the system, the README now says t

[PATCH] include: add an X_DEBUG message type

2012-03-13 Thread Peter Hutterer
Signed-off-by: Peter Hutterer --- Just a nice-to-have, makes grep a tad easier. include/os.h |1 + os/log.c |5 + 2 files changed, 6 insertions(+), 0 deletions(-) diff --git a/include/os.h b/include/os.h index 48ce329..1e90cc5 100644 --- a/include/os.h +++ b/include/os.h @@ -516

Re: [PATCH xorg-gtest v2 0/9] Switch from a precompiled library to a source distribution

2012-03-13 Thread Christopher James Halse Rogers
On Tue, 2012-03-13 at 22:30 -0400, Gaetan Nadon wrote: > On 12-03-13 08:53 PM, Gaetan Nadon wrote: > > On 12-03-13 02:47 PM, Chase Douglas wrote: > > > The major change in this round is to patch 8. Instead of instructing > > > users to > > > include an automake snippet installed on the system, th

Re: server-1.12-branch

2012-03-13 Thread Keith Packard
<#part sign=pgpmime> On Tue, 13 Mar 2012 22:56:55 +, Daniel Stone wrote: > Ooh right, I'll do that too. Have you got the exact commands you used? I can't find anything remaining from that, but I used objdump -d :-) -- keith.pack...@intel.com ___

Re: server-1.12-branch

2012-03-13 Thread Keith Packard
<#part sign=pgpmime> On Wed, 14 Mar 2012 01:45:47 +, Daniel Stone wrote: > I can definitely see the argument here. Keith, do you want me to send > you an automated whole-tree changeset, followed by a series of > cleanups? To be honest, I've only got Xext totally cleaned up right > now, so I

[PATCH synaptics 4/4] Hook ps2comm debugs in to the same debug macro

2012-03-13 Thread Peter Hutterer
Verbosity level 10, because this stuff is really noisy. Signed-off-by: Peter Hutterer --- src/alpscomm.c | 49 + src/ps2comm.c | 163 +++ src/ps2comm.h |2 +- 3 files changed, 106 insertions(+), 108 deletions(-) diff -

[PATCH synaptics 3/4] Add a few debug messages for circular scrolling debugging

2012-03-13 Thread Peter Hutterer
Signed-off-by: Peter Hutterer --- src/synaptics.c |3 +++ 1 files changed, 3 insertions(+), 0 deletions(-) diff --git a/src/synaptics.c b/src/synaptics.c index 1d280ca..375ecb6 100644 --- a/src/synaptics.c +++ b/src/synaptics.c @@ -2560,6 +2560,7 @@ HandleScrolling(SynapticsPrivate *priv, st

[PATCH synaptics 2/4] Add a Debug Level property for run-time debugging

2012-03-13 Thread Peter Hutterer
And fix the current DBG macro to also print the function name. Signed-off-by: Peter Hutterer --- include/synaptics-properties.h |5 +++ man/synaptics.man | 12 +++- src/properties.c | 14 + src/ps2comm.c | 25 --- src/

[PATCH synaptics 1/4] ps2comm: replace nested debug macro function call with single function call

2012-03-13 Thread Peter Hutterer
Signed-off-by: Peter Hutterer --- src/ps2comm.c | 60 1 files changed, 30 insertions(+), 30 deletions(-) diff --git a/src/ps2comm.c b/src/ps2comm.c index 5b34414..63022c0 100644 --- a/src/ps2comm.c +++ b/src/ps2comm.c @@ -77,9 +77,9 @@

[PATCH synaptics] Fix inverted circular scrolling direction

2012-03-13 Thread Peter Hutterer
Introduced in 26831a6eeac6762ad4d99532f62ebbab0827de10. In said commit, the old-style button events were changed to delta accumulation. Alas, for circular scrolling, a positive delta is up whereas for everything else a positive delta is down. Reported-by: Thomas Bächler Signed-off-by: Peter Hutte

Re: [PATCH xorg-gtest v2 0/9] Switch from a precompiled library to a source distribution

2012-03-13 Thread Gaetan Nadon
On 12-03-13 08:53 PM, Gaetan Nadon wrote: > On 12-03-13 02:47 PM, Chase Douglas wrote: >> The major change in this round is to patch 8. Instead of instructing users to >> include an automake snippet installed on the system, the README now says to >> copy >> the snippet into the project. The snippe

Re: libXt 1.1.2 has regressions too

2012-03-13 Thread Alan Coopersmith
Okay, I'll try to get a 1.1.3 release out this week - thanks for the quick response & fix. On 03/12/12 11:56 PM, Jeremy Huddleston wrote: I reverted the commit which caused the regressions in libXt-1.1.2. The issue was that libXt was retrying when it got a POLLHUP rather than passing it along

Re: libXft 2.3.0 not so good

2012-03-13 Thread Alan Coopersmith
Thanks for the fix! On 03/12/12 11:58 PM, Jeremy Huddleston wrote: The bold bug is fixed in git, but the other one I'm not so sure about. I agree that the screenshots are different, but I'm no expert on what is "correct" so hopefully someone else with more font skills can chime in. --Jeremy

Re: server-1.12-branch

2012-03-13 Thread Daniel Stone
Hi, On 14 March 2012 01:30, Jeremy Huddleston wrote: > id rather have a single 100% automated commit followed by 1 or more cleanups. >  Could we do this simultaneously on all the stable branches that people care > about (1.10+ I think), so cherry-picks are less painful? I can definitely see th

Re: server-1.12-branch

2012-03-13 Thread Jeremy Huddleston
id rather have a single 100% automated commit followed by 1 or more cleanups. Could we do this simultaneously on all the stable branches that people care about (1.10+ I think), so cherry-picks are less painful? Sent from my iPhone... On Mar 13, 2012, at 15:56, Daniel Stone wrote: > Hi, > >

Re: [PATCH xorg-gtest v2 0/9] Switch from a precompiled library to a source distribution

2012-03-13 Thread Gaetan Nadon
On 12-03-13 02:47 PM, Chase Douglas wrote: > The major change in this round is to patch 8. Instead of instructing users to > include an automake snippet installed on the system, the README now says to > copy > the snippet into the project. The snippet needs to be available before > autoreconf is r

Re: [PATCH macros 1/2] Fix cflag test compiler message and cache ids

2012-03-13 Thread Chase Douglas
On 03/12/2012 03:47 PM, Jon TURNEY wrote: > On 12/03/2012 22:39, Chase Douglas wrote: >> On 03/12/2012 02:28 PM, Gaetan Nadon wrote: >>> On 12-03-12 02:57 PM, Chase Douglas wrote: When the language is C++, the flag checking message references $CC instead of $CXX. The cache id is also xorg

Re: server-1.12-branch

2012-03-13 Thread Daniel Stone
Hi, On 9 March 2012 22:47, Keith Packard wrote: > On Fri, 09 Mar 2012 12:56:52 -0800, Alan Coopersmith > wrote: >> Are you going to pull in Daniel's code style change now?   Of all the -next >> candidates from the last few months, that was the biggest I remember. > > Yes, that needs to happen n

[PATCH xorg-gtest v2 9/9] Allow user to override default Xorg server binary

2012-03-13 Thread Chase Douglas
This can be accomplished by compiling xorg-gtest with -DDEFAULT_XORG_SERVER=path/to/Xorg. Signed-off-by: Chase Douglas --- src/defines.h |6 +- 1 files changed, 5 insertions(+), 1 deletions(-) diff --git a/src/defines.h b/src/defines.h index 3bfc1da..3fb3304 100644 --- a/src/defines.h +

[PATCH xorg-gtest v2 8/9] Ship xorg-gtest.m4 and Makefile-xorg-gtest.am

2012-03-13 Thread Chase Douglas
See README for instructions on how to use them. Signed-off-by: Chase Douglas --- Makefile.am|2 +- README | 41 +++-- aclocal/Makefile.am| 27 +++ aclocal/xorg-gtest.m4 | 105 +++

[PATCH xorg-gtest v2 7/9] Install, but do not build into a library, the xorg-gtest sources

2012-03-13 Thread Chase Douglas
This mimics the Google Test distribution mechanism. See: http://code.google.com/p/googletest/wiki/FAQ#Why_is_it_not_recommended_to_install_a_pre-compiled_copy_of_Goog Signed-off-by: Chase Douglas --- configure.ac | 10 +++--- src/Makefile.am| 41 +--

[PATCH xorg-gtest v2 6/9] Build gtest as part of the project

2012-03-13 Thread Chase Douglas
Google Test does not recommend using precompiled gtest libraries. See: http://code.google.com/p/googletest/wiki/FAQ#Why_is_it_not_recommended_to_install_a_pre-compiled_copy_of_Goog This change modifies the build system so the examples build the gtest and xorg-gtest libraries and link against the

[PATCH xorg-gtest v2 5/9] Provide meta-source file xorg-gtest-all.cpp

2012-03-13 Thread Chase Douglas
This will make compiling the project each time it is used much easier. Signed-off-by: Chase Douglas --- src/Makefile.am|5 + src/xorg-gtest-all.cpp | 31 +++ 2 files changed, 32 insertions(+), 4 deletions(-) create mode 100644 src/xorg-gtest-all.cpp

[PATCH xorg-gtest v2 4/9] Rename main.cpp to xorg-gtest_main.cpp

2012-03-13 Thread Chase Douglas
This matches the library name and will help with understanding what the includes since we are now shipping the source code. Signed-off-by: Chase Douglas --- src/Makefile.am |2 +- src/main.cpp| 131 --- src/xorg-gtest_main.cpp

[PATCH xorg-gtest v2 3/9] Add a meta-header xorg-gtest.h

2012-03-13 Thread Chase Douglas
The header merely includes all the other headers. It will make building xorg-gtest into each project easier. Signed-off-by: Chase Douglas --- configure.ac|1 + include/Makefile.am |8 +++- include/xorg/gtest/xorg-gtest.h | 34

[PATCH xorg-gtest v2 2/9] Install xorg-gtest source code in $(prefix)/src/xorg-gtest

2012-03-13 Thread Chase Douglas
Google Test suggests that source code be built into each test rather than use a pre-compiled library. This change follows their lead and installs the xorg-gtest source code. Signed-off-by: Chase Douglas --- src/Makefile.am |3 +++ 1 files changed, 3 insertions(+), 0 deletions(-) diff --git

[PATCH xorg-gtest v2 1/9] Move xorg-gtest.cpp to xorg-gtest-example.cpp

2012-03-13 Thread Chase Douglas
This makes the source file match the built executable. Signed-off-by: Chase Douglas --- examples/Makefile.am|2 +- examples/xorg-gtest-example.cpp | 18 ++ examples/xorg-gtest.cpp | 18 -- 3 files changed, 19 insertions(+), 19 deletions

[PATCH xorg-gtest v2 0/9] Switch from a precompiled library to a source distribution

2012-03-13 Thread Chase Douglas
The major change in this round is to patch 8. Instead of instructing users to include an automake snippet installed on the system, the README now says to copy the snippet into the project. The snippet needs to be available before autoreconf is run. It would be possible to copy the snippet into plac

Re: [RFC PATCH 1/2] test: Proof of concept xfixes intergration tests.

2012-03-13 Thread Chase Douglas
On 03/12/2012 09:50 PM, Christopher James Halse Rogers wrote: > --- > > This is not intended to be applied as-is; the autofoo will want changing > to match the changes in xorg-gtest recently submitted to the list. I'll be posting the xorg-gtest autofoo changes again today (hopefully :). Please gi

Re: [PATCH synaptics v5 00/18] Clickpad patches

2012-03-13 Thread Chase Douglas
On 03/12/2012 11:37 PM, Peter Hutterer wrote: > > New additions since v4: > - middle button emulation disabled on clickpads. You can enable it later if > you feel like it. aim for the right foot, it hurts more. > - some cleanup patches that I didn't really end up needing, but, well, now > that

[PATCH video-vmware] config: move AC_SYS_LARGEFILE in autoconf init section

2012-03-13 Thread Gaetan Nadon
There is no need for this statement to be conditionally included. It adds support for large files without taking anything away. http://www.gnu.org/software/autoconf/manual/autoconf.html Signed-off-by: Gaetan Nadon --- configure.ac |2 +- 1 files changed, 1 insertions(+), 1 deletions(-) dif

XQuartz tablet mouse events are at the wrong location and other Xinput headaches

2012-03-13 Thread Jeremy Huddleston
Hey Peter, I'm having an Xi week here in XQuartz. I just received a bug report (http://xquartz.macosforge.org/trac/ticket/555) that tablet support has regressed in XQuartz in 1.12.0 from 1.11.4. The DDX code in both versions is practically the same, so I think this might be a regression somew

Re: [PATCH 1/5] Xext: drop InitServertime() declaration.

2012-03-13 Thread Jeremy Huddleston
Series (1-3, 4v2, 5): Reviewed-by: Jeremy Huddleston On Mar 12, 2012, at 4:20 PM, Peter Hutterer wrote: > Not implemented anywhere. > > Signed-off-by: Peter Hutterer > --- > Xext/syncsrv.h |2 -- > 1 files changed, 0 insertions(+), 2 deletions(-) > > diff --git a/Xext/syncsrv.h b/Xext/syn

Re: libXft 2.3.0 not so good

2012-03-13 Thread Jeremy Huddleston
The bold bug is fixed in git, but the other one I'm not so sure about. I agree that the screenshots are different, but I'm no expert on what is "correct" so hopefully someone else with more font skills can chime in. --Jeremy On Mar 12, 2012, at 8:06 AM, Alan Coopersmith wrote: > Distro make