On Nov 24, 2008, at 4:59 PM, Chris Hostetter wrote:


: The structure we had made some sense before solrj because a dependancy on
: "core."  Specifically I think we should have:
:
: src/solrj   (this will have common & client/src/solrj/*)

the name "solrj" seems odd in that case ... "common" seems like it would
make more sense, since it's code that is common to both clients and
servers


The dependency graph looks like:
common > solrj > solr > servlet
(while EmbeddedSolrServer depend on solr)

calling common+solrj "common" is a little strange because it would not be common to anything anymore: it is the client.



: src/java  (as is, but  common would be moved to solrj)

...if we're going to move things around and rename directories, we might as well rename this as well, since there is now "java" code in multiple
places.  "core" or "server" perhaps?


"core" is bad -- the name is already overloaded, and typically "core" would be the center, not an edge of the dependency graph.
"server" seems good though.

In the end, what do we want the jar files to be called? I think this would look ok:
 solr-client-1.4.jar
 solr-server-1.4.jar

we would also want to move (org.apache.solr.client.solrj.embedded) into solr-server.jar

ryan

Reply via email to