Mindaugas Rasiukevicius <[email protected]> writes:

> Taylor R Campbell <[email protected]> wrote:
>>    Date: Mon, 7 Apr 2014 16:56:58 +0100
>>    From: Mindaugas Rasiukevicius <[email protected]>
>> 
>>    What is "intern"?
>> 
>> `Intern' means `lookup, or create and insert if not there'.
>
> The point being is that I do not find it meaningful/intuitive.  Many other
> systems just use get().  If you want more accurate name, I suggest conget()
> or something more meaningful.

Agreed that it may be surprising, but intern has a long history of that
kind of meaning in Lisp:

http://www.lispworks.com/documentation/HyperSpec/Body/f_intern.htm

Attachment: pgp0bU40T0rIr.pgp
Description: PGP signature

Reply via email to