Hi Victor,

* to get also the failed transactions (completed with negative replies) you need to set the failed_transaction_flag

* if during serial forking you want to log some of the intermediary failed branches, you need to set the log|radius|db_missed_flag
** this flag will log the next failed branch as a “FAILED” event
** the flag will be automatically reset after the branch completion
** IMPORTANT: this flag triggers accounting when a branch fails (on the client side), when failed_transaction_flag triggers accounting when the whole transaction fails (on the server side) as the name says, it is useful for accounting the the “missed call” event during serial forking.

Let me know if this helps in understanding the difference between missed call and failed transaction

Regards,
Bogdan

Victor Gamov wrote:
Any comments about doc/module enhancing ?

Victor Gamov wrote:
Bogdan-Andrei Iancu wrote:
Hi Victor,

I just gave it a try (with 1.3) using your acc config (but to syslog) and I got a record.

Do you get any errors in the script? can you try using the syslog acc?

Hi Bogdan!

Thanks for your attention. It was a my misunderstanding and following misconfiguration for "failed transactions" and "missed calls".

ACC module use "db_table_missed_calls" value to write failed transactions. When I set this parameter to my accounting table then everything is OK.

But I think that some clarifying for this in module documentation needed. Now module have following parameters (general and DB specific):

"failed_transaction_flag" -- Per transaction flag which says if the transaction should be accounted also in case of failure (status>=300).

"db_missed_flag" -- Request flag which needs to be set to account missed calls

"db_table_missed_calls" -- Table name for accounting missed calls

But what is it means "missing calls"? Failed transaction? or user not founded by USRLOC module? or some other?

If "missing" means "failed" (not founded is "failed" too) then we must change definitions and may be remove "db_missed_flag" parameter. If "missed" and "failed" is very different than new parameter "db_table_failed_calls" may be useful.

Thanks!



_______________________________________________
Users mailing list
Users@openser.org
http://openser.org/cgi-bin/mailman/listinfo/users

Reply via email to