On Tue, 5 Dec 2000, Var1abl3 Var1abl3 wrote:

>
> I am in the process of learning BGP. Say I have two core routers and three
> T3 circuits.  Core1 has a connection to ISP1 and ISP2. Core2 has
> a connection to ISP1.  What would be the best way to setup BGP so that I can
> get the most use out of my circuits.  I have included a sample config
> information below.
>
>
> Core1 ---------------- ISP1
>       \
>        --------------- ISP2
>
> Core2 ---------------- ISP1
>
>
> AS #'s
>
> ISP1 = 100
> ISP2 = 200
> ISP3 = 300

You leave alot out.  So I have to make some assumptions.  For
example, which FE ties the two routers together?  I will make an
assumption.  I will assume you are not a transit AS as well.  What
space are you going to announce?  I will just put your netblocks as /24's,
instead of summarizing.  Sometimes people want to
summarize, sometimes to make it easier, sometimes to save routes.
sometimes people like to deaggregate to get more granulaty in
their control.  assuming the AS for CORE is say 1000.  You would do:

core1
-----
router bgp 1000
 no synchronization
 network 172.18.62.0 mask 255.255.255.0
 network 172.17.11.0 mask 255.255.255.0
 network 172.16.6.0 mask 255.255.255.0
 network 172.19.5.0 mask 255.255.255.0
 network 172.16.4.0 mask 255.255.255.0
 neighbor 172.17.11.15 remote-as 1000
 neighbor 172.17.11.15 update-source FastEthernet0/1
 neighbor 172.17.11.15 version 4
 neighbor 172.17.11.15 next-hop-self
 neighbor 172.16.6.5 remote-as 100
 neighbor 172.16.6.5 update-source Serial1/0
 neighbor 172.16.6.5 version 4
 neighbor 172.16.6.5 next-hop-self
 neighbor 172.19.5.9 remote-as 200
 neighbor 172.19.5.9 update-source Serial1/1
 neighbor 172.19.5.9 version 4
 neighbor 172.19.5.9 next-hop-self

ip route 172.18.62.0 255.255.255.0 null0
ip route 172.17.11.0 255.255.255.0 null0
ip route 172.16.6.0 255.255.255.0 null0
ip route 172.19.5.0 255.255.255.0 null0
ip route 172.16.4.0 255.255.255.0 null0


core2
-----
router bgp 1000
 no synchronization
 network 172.18.62.0 mask 255.255.255.0
 network 172.17.11.0 mask 255.255.255.0
 network 172.16.6.0 mask 255.255.255.0
 network 172.19.5.0 mask 255.255.255.0
 network 172.16.4.0 mask 255.255.255.0
 neighbor 172.17.11.19 remote-as 1000
 neighbor 172.17.11.19 update-source FastEthernet0/1
 neighbor 172.17.11.19 version 4
 neighbor 172.17.11.19 next-hop-self
 neighbor 172.16.4.5 remote-as 300
 neighbor 172.16.4.5 update-source Serial1/0
 neighbor 172.16.4.5 version 4
 neighbor 172.16.4.5 next-hop-self


ip route 172.18.62.0 255.255.255.0 null0
ip route 172.17.11.0 255.255.255.0 null0
ip route 172.16.6.0 255.255.255.0 null0
ip route 172.19.5.0 255.255.255.0 null0
ip route 172.16.4.0 255.255.255.0 null0


this is just basic.  I would use distribute/filter lists to make sure I
only announced my blocks.  Lots of ways to do this, but really you should
at least take a crack at it first.

Brian


>
> core1
>
> interface FastEthernet0/0
> description Internet Link
> ip address 172.18.62.150 255.255.255.0
> no ip directed-broadcast
> !
> interface FastEthernet0/1
> description Ethernet
> ip address 172.17.11.19 255.255.255.224
> no ip directed-broadcast
> !
> interface Serial1/0
> description T3 Link to isp1
> ip address 172.16.6.6 255.255.255.252
> no ip directed-broadcast
> encapsulation ppp
> !
> interface Serial1/1
> description T3 to isp2
> ip address 172.19.5.10 255.255.255.252
> no ip directed-broadcast
> encapsulation ppp
> !
>
> core2
>
> interface FastEthernet0/0
> description Internet Link
> ip address 172.18.62.25 255.255.255.0
> no ip directed-broadcast
> !
> interface FastEthernet0/1
> description Ethernet
> ip address 172.17.11.15 255.255.255.224
> no ip directed-broadcast
> !
> interface Serial1/0
> description T3 Link to isp1
> ip address 172.16.4.6 255.255.255.252
> no ip directed-broadcast
> encapsulation ppp
> !
>
> _____________________________________________________________________________________
> Get more from the Web.  FREE MSN Explorer download : http://explorer.msn.com
>
> _________________________________
> FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
> Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]
>

-----------------------------------------------
Brian Feeny, CCNP+ATM, CCDP   [EMAIL PROTECTED]
Network Administrator
ShreveNet Inc. (ASN 11881)

_________________________________
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]

Reply via email to