Jacek,

You can run BGP, it doesn't matter that your router is only a 2611. What
matters is how many routes you receive from your ISP (or from both ISPs as
is your case). True, your router might not be too happy getting 97,000+
routes from both ISP's, but who says you need any routes from your ISP.?.

Not knowing your true config leaves questions. So let me make some
assumptions. Look at this from 4 perspectives. Outbound/Inbound with ISP A
and Outbound/Inbound with ISP B.

ISP A (Outbound)
You could set your default route out to serial 0. This would make ISP A your
primary path out. 
ISP A (Inbound)
You don't need any routes from this ISP if it's your default out anyway.
Adding another twist, suppose you have a /24. You could advertise a couple
/25's to this ISP (if they'll let you), via the BGP that you turn on with
them.

ISP B (Outbound)
You could set another default (weighted) to make ISP B your secondary route
out via serial 1. You don't need this ISP to send you routes if they are
merely a default route out.
ISP B (Inbound)
Again, using the example that you have a /24, you could advertise some other
/25's to this ISP (if they'll let you).

Summary
You'll most likely need your own AS. Alot of providers don't like routing to
a customer if that customer is multi-homed and doesn't have their own AS. By
breaking up the /24 and sending some of it to one provider and some of it to
the other provider, you can build in some "resilience" in case one ISP's
routing breaks or one of your WAN lines drop. That way, people can always
reach atleast some of the networks you have onsite. To further add
"resilience", advertise to ISP A the networks your sending to ISP B with
heavy weights (AS-Path prepend, Local Pref, etc..keeping in mind that some
attributes are Transitive and some are not). That way if ISP B breaks, all
of your networks will now be available via ISP A. Do the same for ISP B,
advertise your ISP A advertised networks with a larger value so that if ISP
A breaks, ISP B can now advertise all of your routes. 

Hope this helps
Chris

-----Original Message-----
From: Jacek Malinowski [mailto:[EMAIL PROTECTED]]
Sent: Saturday, March 03, 2001 9:27 AM
To: [EMAIL PROTECTED]
Subject: Route-map


I have a big problem with the route-map command.
My network looks like :

        ISP A                     ISP B
          |                         |
          |                         |
          |                         |
          --s0--(router 2611)--- s1--

configuration (hypothetical):

interface Serial0
 ip address 1.1.1.1 255.255.255.0
  !
interface Serial1
 ip address 100.100.100.100 255.255.255.0
!
interface FastEthernet0
 ip address 10.0.0.222 255.255.255.0 secondary
 ip address 192.168.1.1 255.255.255.0
 ip policy route-map POLICY
 no ip directed-broadcast
!
ip classless
ip route 0.0.0.0 0.0.0.0 Serial1
no ip http server
!
access-list 2 permit 10.0.0.0 0.0.0.255
route-map POLICY permit 10
 match ip address 2
 set ip next-hop 1.1.1.1

traffic from the network 10.0.0.0 should go through serial 0 and ISP A
traffic from the network 192.168.1.0 should go through serial 1 and ISP B.

I don't understand how is it possible, that ping from 10.0.0.0 goes through
serial 1 and return through serial 0.
there is the policy on the ethernet interface.

I can't run BGP :( because my router is only 2611




_________________________________
FAQ, list archives, and subscription info:
http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]

_________________________________
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]

Reply via email to