Since Maven is so good at generating docs, I'm starting to favor useful xdocs over long package descriptions. It just seems easier to navigate.
Now onto the code: I have some ideas that I'd like to mention.
----------------------------------------------------------------
Packages o.a.c.io.input and o.a.c.io.output
----------------------------------------------------------------
I'd like to merge these into one package which contains all InputStreams, OutputStreams, Readers and Writers. Currently, we have 1 Writer, 0 Readers, and the rest are streams. I just think it makes more sense to have these classes side by side. For example -- ProxyInputStream and ProxyOutputStream, DemuxInputStream and DemuxOutputStream. These classes will most like be used together, and change together, so lets put them together.
Here are some ideas for a name:
o.a.c.io.throughput - kind of vague
o.a.c.io.streams - good, but there may be readers, writers also
o.a.c.io - what about putting them in the root package similar to java.io
---------------------------------------------------------------- class o.a.c.io.HexDump ----------------------------------------------------------------
This class only has one method, dump(byte[], long, OutputStream, int). I would like to move this method to IOUtils as dumpHex, then deprecate and remove the original class.
Please chime in with any comments or suggestions.
--------------------------------------------------------------------- To unsubscribe, e-mail: [EMAIL PROTECTED] For additional commands, e-mail: [EMAIL PROTECTED]
