On Thu, 23 Apr 2026 20:59:06 GMT, Alexey Semenyuk <[email protected]> wrote:
> JPackageStringBundle: move FormattedMessage class to the top level, rename it > to CannedMessageFormat, and make it public. > The CannedMessageFormat class can be used to create a format string bound to > the format string arguments, where the format string is loaded from a string > bundle or picked from any other source > > Additionally: > - JPackageCommand: support running jpackage with modified environment > variables > - LinuxHelper: expose `getReleaseSuffix()` > - JPackageCommand: add `fullVersion()` based on > `LinuxHelper.getReleaseSuffix()` > > --------- > - [x] I confirm that I make this contribution in accordance with the [OpenJDK > Interim AI Policy](https://openjdk.org/legal/ai). Looks good with minor comments. test/jdk/tools/jpackage/helpers-test/jdk/jpackage/test/CannedFormattedStringTest.java line 100: > 98: assertEquals("Bye Duke!", c.getValue()); > 99: > 100: assertEquals("Repeated messagge: Hello Duke! Hello Duke!", > a.addPrefix("Repeated messagge: {0} {0}").getValue()); `messagge` -> `message` test/jdk/tools/jpackage/helpers/jdk/jpackage/test/CannedMessageFormat.java line 70: > 68: } > 69: > 70: public static CannedMessageFormat create(String > messageFormatFormatString, Object... args) { `messageFormatFormatString` -> `formatString`? or any better name. This one is confusing. ------------- PR Review: https://git.openjdk.org/jdk/pull/30906#pullrequestreview-4173437998 PR Review Comment: https://git.openjdk.org/jdk/pull/30906#discussion_r3140323088 PR Review Comment: https://git.openjdk.org/jdk/pull/30906#discussion_r3140399686
