devel
Thread
Date
Earlier messages
Later messages
Messages by Thread
Re: [PATCH 4/4] ppc/pnv: Remove Power8E and Power8NVL CPUs
Philippe Mathieu-Daudé via Devel
Re: [PATCH 4/4] ppc/pnv: Remove Power8E and Power8NVL CPUs
Cédric Le Goater via Devel
Re: [PATCH 4/4] ppc/pnv: Remove Power8E and Power8NVL CPUs
Aditya Gupta
Re: [PATCH 0/4] Remove deprecated Power8E and 8NVL CPUs
Cédric Le Goater via Devel
[PATCH v2 0/2] lxc: Assign aliases to filesystem and network devices
Radosław Śmigielski via Devel
[PATCH v2 1/2] lxc: Assign aliases to filesystem devices
Radosław Śmigielski via Devel
Re: [PATCH v2 1/2] lxc: Assign aliases to filesystem devices
Michal Prívozník via Devel
[PATCH v2 2/2] lxc: Assign aliases to network interface devices
Radosław Śmigielski via Devel
Re: [PATCH v2 2/2] lxc: Assign aliases to network interface devices
Michal Prívozník via Devel
[PATCH 00/20] qemu: Fix virtio video devcice frontend selection logic for migrations
Peter Krempa via Devel
[PATCH 01/20] qemu: capabilities: Apply 'capability_filters' configration option on all capabilities
Peter Krempa via Devel
[PATCH 02/20] qemu: capabilities: Export 'virQEMUCapsNewCopy' outside of 'qemu_capspriv'
Peter Krempa via Devel
[PATCH 03/20] qemu: Allow reuse of 'qemuProcessStartUpdateCustomCaps'
Peter Krempa via Devel
[PATCH 04/20] qemu: validate: Validate VM config with qemuCaps influenced by <qemu:capabilities>
Peter Krempa via Devel
[PATCH 05/20] qemu: postparse: Process VM config with qemuCaps influenced by <qemu:capabilities>
Peter Krempa via Devel
[PATCH 06/20] virQEMUCapsCacheLookupDefault: Fix error message when no emulators are installed
Peter Krempa via Devel
[PATCH 07/20] qemuxmlconfdata: un-symlink 'video-virtio-vga-gpu-gl' output
Peter Krempa via Devel
[PATCH 08/20] qemuxmlconftest: Add 'video-virtio-vga' invocation with QEMU_CAPS_DEVICE_VIRTIO_VGA disabled
Peter Krempa via Devel
[PATCH 09/20] qemuxmlconftest: Add test cases for configs asking for 'virtio-gpu-gl' or 'virtio-vga-gl' without the capability
Peter Krempa via Devel
[PATCH 10/20] qemuxmlconftest: Add invocation of 'video-virtio-vga-gpu-gl' with missing caps and VIR_DOMAIN_DEF_PARSE_ABI_UPDATE
Peter Krempa via Devel
[PATCH 12/20] virDomainVideoDefFormat: Use 'virXMLFormatElement' instead of custom formatter
Peter Krempa via Devel
[PATCH 13/20] conf: Add fields for recording actually-selected virtio video device
Peter Krempa via Devel
[PATCH 11/20] qemustatusxml2xml: Add test case capturing virtio video device
Peter Krempa via Devel
[PATCH 14/20] qemuxmlconftest: Add test case for specifying 'virtio-gpu' where 'virtio-vga' would be picked
Peter Krempa via Devel
[PATCH 15/20] qemuDeviceVideoGetModel: Directly return picked model
Peter Krempa via Devel
[PATCH 16/20] qemu: postparse: Fill in selected virtio video frondend device in the XML
Peter Krempa via Devel
[PATCH 18/20] qemuDeviceVideoGetModel: Remove logic for selecting 'virtio' devices
Peter Krempa via Devel
[PATCH 19/20] qemuDeviceVideoGetModel: Simplify by relying on checks from 'qemuValidateDomainDeviceDefVideo'
Peter Krempa via Devel
[PATCH 17/20] qemuValidateDomainDeviceDefVideo: Fix checks of virtio video devices
Peter Krempa via Devel
[PATCH 20/20] qemu: Remove 'qemuDomainSupportsVideoVga'
Peter Krempa via Devel
Re: [PATCH 00/20] qemu: Fix virtio video devcice frontend selection logic for migrations
Michal Prívozník via Devel
[PATCH] lxc: Assign aliases to filesystem devices
Radosław Śmigielski via Devel
Re: [PATCH] lxc: Assign aliases to filesystem devices
Radoslaw Smigielski via Devel
primepornreview website
yifimit442--- via Devel
[PATCH v2 00/35] monitor: turn QMP and HMP into QOM objects
Daniel P . Berrangé via Devel
[PATCH v2 01/35] qom: replace 'can_be_deleted' with 'prepare_delete'
Daniel P . Berrangé via Devel
Re: [PATCH v2 01/35] qom: replace 'can_be_deleted' with 'prepare_delete'
marcandre.lureau--- via Devel
[PATCH v2 02/35] monitor: replace 'common' with 'parent_obj' in MonitorHMP
Daniel P . Berrangé via Devel
Re: [PATCH v2 02/35] monitor: replace 'common' with 'parent_obj' in MonitorHMP
marcandre.lureau--- via Devel
[PATCH v2 04/35] monitor: rename monitor_init* to monitor_new*
Daniel P . Berrangé via Devel
Re: [PATCH v2 04/35] monitor: rename monitor_init* to monitor_new*
marcandre.lureau--- via Devel
[PATCH v2 03/35] monitor: replace 'common' with 'parent_obj' in MonitorQMP
Daniel P . Berrangé via Devel
Re: [PATCH v2 03/35] monitor: replace 'common' with 'parent_obj' in MonitorQMP
marcandre.lureau--- via Devel
[PATCH v2 05/35] monitor: minimal conversion of monitors to QOM
Daniel P . Berrangé via Devel
Re: [PATCH v2 05/35] monitor: minimal conversion of monitors to QOM
marcandre.lureau--- via Devel
[PATCH v2 06/35] monitor: add 'chardev' property to Monitor base class
Daniel P . Berrangé via Devel
Re: [PATCH v2 06/35] monitor: add 'chardev' property to Monitor base class
marcandre.lureau--- via Devel
Re: [PATCH v2 06/35] monitor: add 'chardev' property to Monitor base class
Daniel P . Berrangé via Devel
[PATCH v2 07/35] monitor: add 'readline' property to HMP Monitor class
Daniel P . Berrangé via Devel
Re: [PATCH v2 07/35] monitor: add 'readline' property to HMP Monitor class
marcandre.lureau--- via Devel
[PATCH v2 08/35] monitor: add 'pretty' property to QMP Monitor class
Daniel P . Berrangé via Devel
Re: [PATCH v2 08/35] monitor: add 'pretty' property to QMP Monitor class
marcandre.lureau--- via Devel
[PATCH v2 10/35] monitor: move monitor_data_(init|destroy) into QOM init/finalize
Daniel P . Berrangé via Devel
Re: [PATCH v2 10/35] monitor: move monitor_data_(init|destroy) into QOM init/finalize
marcandre.lureau--- via Devel
[PATCH v2 09/35] monitor: remove 'skip_flush' field
Daniel P . Berrangé via Devel
Re: [PATCH v2 09/35] monitor: remove 'skip_flush' field
marcandre.lureau--- via Devel
[PATCH v2 12/35] monitor: use class methods for monitor_qapi_event_emit
Daniel P . Berrangé via Devel
Re: [PATCH v2 12/35] monitor: use class methods for monitor_qapi_event_emit
marcandre.lureau--- via Devel
[PATCH v2 11/35] monitor: use class methods for monitor_vprintf
Daniel P . Berrangé via Devel
Re: [PATCH v2 11/35] monitor: use class methods for monitor_vprintf
marcandre.lureau--- via Devel
[PATCH v2 13/35] monitor: use class methods for monitor_accept_input
Daniel P . Berrangé via Devel
Re: [PATCH v2 13/35] monitor: use class methods for monitor_accept_input
marcandre.lureau--- via Devel
[PATCH v2 14/35] monitor: use class method for I/O thread request
Daniel P . Berrangé via Devel
Re: [PATCH v2 14/35] monitor: use class method for I/O thread request
marcandre.lureau--- via Devel
[PATCH v2 16/35] util: use dynamic cast in error vreport
Daniel P . Berrangé via Devel
Re: [PATCH v2 16/35] util: use dynamic cast in error vreport
marcandre.lureau--- via Devel
[PATCH v2 15/35] monitor: use dynamic cast in monitor_qmp_requests_pop_any_with_lock
Daniel P . Berrangé via Devel
Re: [PATCH v2 15/35] monitor: use dynamic cast in monitor_qmp_requests_pop_any_with_lock
marcandre.lureau--- via Devel
[PATCH v2 17/35] monitor: drop unused monitor_cur_is_qmp
Daniel P . Berrangé via Devel
Re: [PATCH v2 17/35] monitor: drop unused monitor_cur_is_qmp
marcandre.lureau--- via Devel
[PATCH v2 19/35] monitor: use dynamic cast in monitor_is_hmp_non_interactive
Daniel P . Berrangé via Devel
Re: [PATCH v2 19/35] monitor: use dynamic cast in monitor_is_hmp_non_interactive
marcandre.lureau--- via Devel
[PATCH v2 20/35] monitor: drop unused monitor_is_qmp method
Daniel P . Berrangé via Devel
Re: [PATCH v2 20/35] monitor: drop unused monitor_is_qmp method
marcandre.lureau--- via Devel
[PATCH v2 18/35] monitor: use dynamic cast in QMP commands
Daniel P . Berrangé via Devel
Re: [PATCH v2 18/35] monitor: use dynamic cast in QMP commands
marcandre.lureau--- via Devel
[PATCH v2 22/35] monitor: implement "user creatable" interface for adding monitors
Daniel P . Berrangé via Devel
Re: [PATCH v2 22/35] monitor: implement "user creatable" interface for adding monitors
marcandre.lureau--- via Devel
[PATCH v2 21/35] monitor: eliminate monitor_is_hmp_non_interactive method
Daniel P . Berrangé via Devel
Re: [PATCH v2 21/35] monitor: eliminate monitor_is_hmp_non_interactive method
marcandre.lureau--- via Devel
[PATCH v2 23/35] qemu-options: document new monitor-hmp and monitor-qmp objects
Daniel P . Berrangé via Devel
Re: [PATCH v2 23/35] qemu-options: document new monitor-hmp and monitor-qmp objects
marcandre.lureau--- via Devel
Re: [PATCH v2 23/35] qemu-options: document new monitor-hmp and monitor-qmp objects
Daniel P . Berrangé via Devel
[PATCH v2 24/35] monitor: convert from oneshot BH to persistent BH
Daniel P . Berrangé via Devel
Re: [PATCH v2 24/35] monitor: convert from oneshot BH to persistent BH
marcandre.lureau--- via Devel
[PATCH v2 26/35] monitor: protect qemu_chr_fe_accept_input with monitor lock
Daniel P . Berrangé via Devel
Re: [PATCH v2 26/35] monitor: protect qemu_chr_fe_accept_input with monitor lock
marcandre.lureau--- via Devel
[PATCH v2 28/35] tests/qtest: add tests for dynamic monitor add/remove
Daniel P . Berrangé via Devel
Re: [PATCH v2 28/35] tests/qtest: add tests for dynamic monitor add/remove
marcandre.lureau--- via Devel
[PATCH v2 27/35] monitor: implement support for deleting QMP objects
Daniel P . Berrangé via Devel
Re: [PATCH v2 27/35] monitor: implement support for deleting QMP objects
marcandre.lureau--- via Devel
Re: [PATCH v2 27/35] monitor: implement support for deleting QMP objects
Daniel P . Berrangé via Devel
[PATCH v2 29/35] tests/functional: add e2e test for dynamic QMP monitor hotplug
Daniel P . Berrangé via Devel
Re: [PATCH v2 29/35] tests/functional: add e2e test for dynamic QMP monitor hotplug
marcandre.lureau--- via Devel
[PATCH v2 25/35] monitor: reject attempts to delete the current monitor
Daniel P . Berrangé via Devel
Re: [PATCH v2 25/35] monitor: reject attempts to delete the current monitor
marcandre.lureau--- via Devel
[PATCH v2 31/35] qom: add method for getting the "id" of a QOM object
Daniel P . Berrangé via Devel
Re: [PATCH v2 31/35] qom: add method for getting the "id" of a QOM object
marcandre.lureau--- via Devel
Re: [PATCH v2 31/35] qom: add method for getting the "id" of a QOM object
Daniel P . Berrangé via Devel
[PATCH v2 33/35] monitor: add support for auto-deleting monitors upon close
Daniel P . Berrangé via Devel
Re: [PATCH v2 33/35] monitor: add support for auto-deleting monitors upon close
marcandre.lureau--- via Devel
Re: [PATCH v2 33/35] monitor: add support for auto-deleting monitors upon close
Daniel P . Berrangé via Devel
[PATCH v2 30/35] tests/functional: add a stress test for monitor hot unplug
Daniel P . Berrangé via Devel
Re: [PATCH v2 30/35] tests/functional: add a stress test for monitor hot unplug
marcandre.lureau--- via Devel
Re: [PATCH v2 30/35] tests/functional: add a stress test for monitor hot unplug
Daniel P . Berrangé via Devel
[PATCH v2 32/35] qom: add trace events for user creatable create/delete APIs
Daniel P . Berrangé via Devel
Re: [PATCH v2 32/35] qom: add trace events for user creatable create/delete APIs
marcandre.lureau--- via Devel
[PATCH v2 34/35] tests: switch from -mon to -object monitor-qmp
Daniel P . Berrangé via Devel
Re: [PATCH v2 34/35] tests: switch from -mon to -object monitor-qmp
marcandre.lureau--- via Devel
[PATCH v2 35/35] docs: mark '-mon' as deprecated in favour of -object
Daniel P . Berrangé via Devel
Re: [PATCH v2 35/35] docs: mark '-mon' as deprecated in favour of -object
marcandre.lureau--- via Devel
[PATCH v2 0/5] qemu: add async vCPU unplug coverage
Akash Kulhalli via Devel
[PATCH v2 2/5] tests: add helper for DEVICE_DELETED events
Akash Kulhalli via Devel
[PATCH v2 1/5] qemu: expose process event handler to tests
Akash Kulhalli via Devel
[PATCH v2 4/5] qemuhotplugtest: test setvcpu async unplug
Akash Kulhalli via Devel
[PATCH v2 3/5] qemuhotplugtest: support async vcpu unplug completion
Akash Kulhalli via Devel
[PATCH v2 5/5] qemuhotplugtest: test setvcpus async downscale
Akash Kulhalli via Devel
Re: [PATCH v2 0/5] qemu: add async vCPU unplug coverage
Peter Krempa via Devel
[PATCH] bhyve: support populating SMBIOS fields
Roman Bogorodskiy
Re: [PATCH] bhyve: support populating SMBIOS fields
Michal Prívozník via Devel
[PATCH] ci: refresh with 'lcitool manifest'
Daniel P . Berrangé via Devel
Re: [PATCH] ci: refresh with 'lcitool manifest'
Pavel Hrdina via Devel
[PATCH] ci: refresh with 'lcitool manifest'
Michal Privoznik via Devel
Re: [PATCH] ci: refresh with 'lcitool manifest'
Pavel Hrdina via Devel
[PATCH] ci: refresh with 'lcitool manifest'
Michal Privoznik via Devel
Re: [PATCH] ci: refresh with 'lcitool manifest'
Ján Tomko via Devel
[PATCH 0/3] implement a few guest agent based APIs
Roman Bogorodskiy
[PATCH 1/3] bhyve: implement domain{Get,Set}Time APIs
Roman Bogorodskiy
[PATCH 3/3] bhyve: implement domainAuthorizedSSHKeys{Get,Set} APIs
Roman Bogorodskiy
[PATCH 2/3] bhyve: implement domainSetUserPassword API
Roman Bogorodskiy
Re: [PATCH 0/3] implement a few guest agent based APIs
Michal Prívozník via Devel
[PATCH 0/2] bhyve: guest agent bugfixes
Roman Bogorodskiy
[PATCH 1/2] bhyve: process: properly handle misconfigured agent
Roman Bogorodskiy
[PATCH 2/2] bhyve: fix domainQemuAgentCommand
Roman Bogorodskiy
Re: [PATCH 0/2] bhyve: guest agent bugfixes
Michal Prívozník via Devel
[PATCH 1/2] bhyve: respect domain's on_poweroff action
Roman Bogorodskiy
[PATCH 2/2] bhyve: respect domain's on_reboot action
Roman Bogorodskiy
Re: [PATCH 2/2] bhyve: respect domain's on_reboot action
Michal Prívozník via Devel
Re: [PATCH 1/2] bhyve: respect domain's on_poweroff action
Michal Prívozník via Devel
[PATCH] domaincapstest: Drop support for old qemu
Michal Privoznik via Devel
Re: [PATCH] domaincapstest: Drop support for old qemu
Ján Tomko via Devel
Re: [PATCH] domaincapstest: Drop support for old qemu
Daniel P . Berrangé via Devel
[PATCH 0/3] tests: Add capability dump data for the qemu-11.1 dev cycle
Peter Krempa via Devel
[PATCH 1/3] qemublocktest: Skip schema validation on 'gluster' backend tests
Peter Krempa via Devel
Re: [PATCH 1/3] qemublocktest: Skip schema validation on 'gluster' backend tests
Michal Prívozník via Devel
Re: [PATCH 1/3] qemublocktest: Skip schema validation on 'gluster' backend tests
Peter Krempa via Devel
Re: [PATCH 1/3] qemublocktest: Skip schema validation on 'gluster' backend tests
Michal Prívozník via Devel
Re: [PATCH 3/3] qemucapabilitiestest: Add data for the qemu-11.1 dev cycle (aarch64)
Michal Prívozník via Devel
Re: [PATCH 2/3] qemucapabilitiestest: Add data for the qemu-11.1 dev cycle (x86_64)
Michal Prívozník via Devel
[PATCH 0/3] hyperv: Add support for detecting nested virtualization capability
Jonathon Jongsma via Devel
[PATCH 1/3] hyperv: fix error handling of hypervGetProcessorsByName()
Jonathon Jongsma via Devel
[PATCH 2/3] hyperv: Rename hypervGetProcessorsByName() to hypervGetProcessorList()
Jonathon Jongsma via Devel
[PATCH 3/3] hyperv: report nested virtualization setting in domain XML
Jonathon Jongsma via Devel
Re: [PATCH 0/3] hyperv: Add support for detecting nested virtualization capability
Michal Prívozník via Devel
[PATCH 0/2] ci: Bump to Debian 13 and drop Cirrus
Michal Privoznik via Devel
[PATCH 2/2] ci: Drop cirrus
Michal Privoznik via Devel
Re: [PATCH 2/2] ci: Drop cirrus
Michal Prívozník via Devel
[PATCH 1/2] ci: regenerate with 'lcitool manifest'
Michal Privoznik via Devel
Re: [PATCH 1/2] ci: regenerate with 'lcitool manifest'
Pavel Hrdina via Devel
[PATCH 0/3] ci: Remove cirrus jobs
Peter Krempa via Devel
[PATCH 1/3] ci: README: Delete section about 'Cirrus CI'
Peter Krempa via Devel
[PATCH 2/3] ci: Drop 'Cirrus CI' job defnitions
Peter Krempa via Devel
[PATCH 3/3] ci: Regenerate with 'lcitool'
Peter Krempa via Devel
Re: [PATCH 3/3] ci: Regenerate with 'lcitool'
Michal Prívozník via Devel
Re: [PATCH 3/3] ci: Regenerate with 'lcitool'
Peter Krempa via Devel
Re: [PATCH 3/3] ci: Regenerate with 'lcitool'
Michal Prívozník via Devel
Re: [PATCH 3/3] ci: Regenerate with 'lcitool'
Peter Krempa via Devel
Re: [PATCH 0/3] ci: Remove cirrus jobs
Peter Krempa via Devel
Re: [PATCH 0/3] ci: Remove cirrus jobs
Michal Prívozník via Devel
[PATCH 0/4] qemu: add API to ammounce guest interfaces to the network
Laine Stump via Devel
[PATCH 1/4] qemu: new monitor function qemuMonitorAnnounceSelf()
Laine Stump via Devel
Re: [PATCH 1/4] qemu: new monitor function qemuMonitorAnnounceSelf()
Martin Kletzander via Devel
Re: [PATCH 1/4] qemu: new monitor function qemuMonitorAnnounceSelf()
Peter Krempa via Devel
[PATCH] test: unit test for qemuMonitorJSONAnnounceSelf()
Laine Stump via Devel
Re: [PATCH] test: unit test for qemuMonitorJSONAnnounceSelf()
Peter Krempa via Devel
Re: [PATCH] test: unit test for qemuMonitorJSONAnnounceSelf()
Laine Stump via Devel
[PATCH 3/4] qemu: implement virDomainAnnounceInterface() API
Laine Stump via Devel
Re: [PATCH 3/4] qemu: implement virDomainAnnounceInterface() API
Martin Kletzander via Devel
Re: [PATCH 3/4] qemu: implement virDomainAnnounceInterface() API
Laine Stump via Devel
[PATCH 2/4] API: Introduce virDomainAnnounceInterface
Laine Stump via Devel
Re: [PATCH 2/4] API: Introduce virDomainAnnounceInterface
Martin Kletzander via Devel
Re: [PATCH 2/4] API: Introduce virDomainAnnounceInterface
Laine Stump via Devel
[PATCH 4/4] virsh: new command "domifannounce"
Laine Stump via Devel
Re: [PATCH 4/4] virsh: new command "domifannounce"
Martin Kletzander via Devel
[PATCHv2] lxc: truncate LOOP_GET_STATUS64.lo_file_name for long loop backing paths
Radoslaw Smigielski via Devel
Release of libvirt-12.4.0
Jiri Denemark via Devel
[PATCH v8 0/4] nwfilter: add nwfilter nftables driver
Dion Bosschieter
[PATCH v8 1/4] nwfilter: add nwfilter nftables driver
Dion Bosschieter
[PATCH v8 2/4] nwfilter: allow use of nftables nwfilter driver via nwfilter.conf
Dion Bosschieter
[PATCH v8 4/4] nwfilter: add used firewall backend to nwfilterbinding
Dion Bosschieter
[RFC patch 00/17] qemu: Unlock VM object while accessing storage (in certain cases)
Peter Krempa via Devel
[RFC patch 01/17] storage_source: Don't modify @src in 'virStorageSourceUpdatePhysicalSize'
Peter Krempa via Devel
[RFC patch 03/17] virStorageFileProbeFormatFromBuf: Allow NULL 'path' argument
Peter Krempa via Devel
[RFC patch 02/17] virStorageSourceGetSize: Return also 'allocation' value if needed
Peter Krempa via Devel
[RFC patch 05/17] virStorageSourceGetMetadataFromBuf: Refactor cleanup
Peter Krempa via Devel
[RFC patch 04/17] virStorageFileProbeGetMetadata: Allow NULL 'meta->path'
Peter Krempa via Devel
[RFC patch 06/17] virStorageSourceUpdateCapacity: Factor out size probing to 'virStorageSourceProbeCapacityFromBuf'
Peter Krempa via Devel
[RFC patch 07/17] qemu: domain: Introduce 'qemuDomainStorageSourceProbeSize'
Peter Krempa via Devel
[RFC patch 08/17] qemuDomainGetBlockInfo: Rewrite to 'qemuDomainStorageSourceProbeSize'
Peter Krempa via Devel
[RFC patch 09/17] qemuDomainGetStatsOneBlock: Rewrite to 'qemuDomainStorageSourceProbeSize'
Peter Krempa via Devel
Earlier messages
Later messages