1. why do you think *_animated_* is not proper name?
long character or grammar problem (word class? Other reason?) ?
*_animated_* is familiar to me, and there is no place related with this in evas 
, so I want to keep this name.
But If this name is wrong  or not acceptable name generally , I will consider 
to change API name. 
2. yes . I already have elm_icon_anim_available_get API
3. elm_icon_anim_set means I will use animation mode currently or later.
    Elm_icon_anim_play_set is for real play of image.

Thanks.

-----Original Message-----
From: Daniel Juyung Seo [mailto:seojuyu...@gmail.com] 
Sent: Monday, July 25, 2011 11:43 PM
To: ChunEon Park
Cc: Jiyoun Park; enlightenment-devel@lists.sourceforge.net
Subject: Re: [E-devel] [Patch] Animation gif feature patch

1)
> Frankely, I don't like *_animated_*
Agreed. Choose either animation or anim and apply it to evas_object_image and 
elm_icon.
I prefer anim :)

2)
> Eina_Bool elm_icon_anim_get (const Evas_Object *obj)
> -> elm_icon_anim_available_get ...
elm_icon_anim_available_get is already in Jiyoun's patch.

3)
API names are not clear. For me 2 names are confusing.
elm_icon_anim_set()
elm_icon_anim_play_set()
What's anim mode and anim play mode? Maybe I'm missing some animation image 
concept.

Thanks.
Daniel Juyung Seo (SeoZ)



On Mon, Jul 25, 2011 at 8:20 PM, ChunEon Park <her...@naver.com> wrote:
> Frankely, I don't like *_animated_*
> How about just animation or anim?
> evas_object_image_animation_available_get
> evas_object_image_animation_frame_get
> ...
> and this API also.
> Eina_Bool elm_icon_anim_get (const Evas_Object *obj)
> -> elm_icon_anim_available_get ...
> ------------------------------------
> Let's run together for the best moment!
>  -Regards, Hermet-
>
> -----Original Message-----
> From: "Jiyoun Park"&lt;jy0703.p...@samsung.com&gt;
> To: enlightenment-devel@lists.sourceforge.net
> Cc:
> Sent: 11-07-25(월) 17:18:22
> Subject: [E-devel] [Patch] Animation gif feature patchHello.
> I modified animated gif feature code according Mike’s advise.
> Added api
> Eina_Bool evas_object_image_animated_get (const Evas_Object *obj) int 
> evas_object_image_animated_frame_num_get (const Evas_Object *obj) 
> Evas_Image_Animated_Loop_Hint evas_object_image_animated_loop_type_get
> (const Evas_Object *obj)
> int evas_object_image_animated_loop_count_get (const Evas_Object *obj) 
> double evas_object_image_animated_frame_duration_get (const 
> Evas_Object *obj, int start_frame, int fram_num) void 
> evas_object_image_animated_frame_set (Evas_Object *obj, int frame_num) 
> Eina_Bool elm_icon_anim_available_get (const Evas_Object *obj) Void 
> elm_icon_anim_set (Evas_Object *obj, Eina_Bool anim) Eina_Bool 
> elm_icon_anim_get (const Evas_Object *obj) void elm_icon_anim_play_set 
> (Evas_Object *obj, Eina_Bool play) Eina_Bool elm_icon_anim_play_get 
> (const Evas_Object *obj) Todo 1. optimization 2. Test case to test 
> several files Test_icon.c is for elm icon test.
> Change test_icon.c in elementary/src/bin to this.
> Thanks.
> ----------------------------------------------
> Jiyoun Park
>
> Mobile S/W Platform Lab
> DMC R&D Center
> SAMSUNG ELECTRONICS CO. ,LTD
>
> TEL: +82-31-279-0619
> Mobile: +82-10-9871-0703
> jy0703.p...@samsung.com
> ----------------------------------------------
> ----------------------------------------------------------------------
> --------
> Storage Efficiency Calculator
> This modeling tool is based on patent-pending intellectual property 
> that has been used successfully in hundreds of IBM storage 
> optimization engage- ments, worldwide.  Store less, Store more with 
> what you own, Move data to the right place. Try It Now! 
> http://www.accelacomm.com/jaw/sfnl/114/51427378/
> _______________________________________________
> enlightenment-devel mailing list
> enlightenment-devel@lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/enlightenment-devel
>


------------------------------------------------------------------------------
Magic Quadrant for Content-Aware Data Loss Prevention
Research study explores the data loss prevention market. Includes in-depth
analysis on the changes within the DLP market, and the criteria used to
evaluate the strengths and weaknesses of these DLP solutions.
http://www.accelacomm.com/jaw/sfnl/114/51385063/
_______________________________________________
enlightenment-devel mailing list
enlightenment-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/enlightenment-devel

Reply via email to