[ 
https://issues.apache.org/jira/browse/HBASE-6411?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13421600#comment-13421600
 ] 

Alex Baranau commented on HBASE-6411:
-------------------------------------

Some more words on incr() in registry. This may actually be OK. Or rather "not 
that big a deal". I.e. to me this interface that we have:
{noformat}
public interface BaseMetricsSource {
  public void setGauge(String gaugeName, long value);
  public void incGauge(String gaugeName, long delta);
  public void decGauge(String gaugeName, long delta);
  public void removeGauge(String key);
  public void incCounters(String counterName, long delta);
  public void removeCounter(String key);
}
{noformat}

looks like "registry description": smth which holds metrics (allows to 
add/remove them by name) and provides read/write access to them _by name_ (if 
one doesn't want to deal with the specific classes/implementations of those 
metrics). I.e. seems not that bad.

That is why I suggested we replace this class with the registry in the first 
place. But OK to leave it.
                
> Move Master Metrics to metrics 2
> --------------------------------
>
>                 Key: HBASE-6411
>                 URL: https://issues.apache.org/jira/browse/HBASE-6411
>             Project: HBase
>          Issue Type: Sub-task
>            Reporter: Elliott Clark
>            Assignee: Elliott Clark
>         Attachments: HBASE-6411-0.patch, HBASE-6411-1.patch, 
> HBASE-6411-2.patch, HBASE-6411_concept.patch
>
>
> Move Master Metrics to metrics 2

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: 
https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Reply via email to