On Thu, 12 Aug 1999 17:23:35 +0900, Shigeru Miyata wrote:

>Arnd, I think I have ported most of your patch to 1.1
>Please check.

-----------
Index: lyx/src/lyxlib.h
===================================================================
RCS file: /usr/local/lyxsrc/cvsroot/lyx/src/lyxlib.h,v
retrieving revision 1.1
diff -u -r1.1 lyxlib.h
--- lyxlib.h    1999/06/30 14:48:29     1.1
+++ lyxlib.h    1999/08/12 07:21:05
@@ -25,7 +25,7 @@
 inline char * date() 
 {
        time_t tid;
-       if ((tid=time(0)) == -1)
+       if ((tid=time(0)) == (time_t)-1)
                return (char*)0;
        else
                return (ctime(&tid));
@@ -46,5 +46,22 @@
                userName = _("unknown");
        return userName;
 }
+
+struct lyx {
+       static char *getcwd(char* buffer, size_t size) {
+#ifndef __EMX__
+               return ::getcwd(buffer, size);
+#else
+               return _getcwd2(buffer, size);
+#endif
+       };
+       static chdir(const char* name) {
+#ifndef __EMX__
+               return ::chdir(name);
+#else
+               return _chdir2(name);
+#endif
+       };
+};
 
-------------

Wouldn't it improve readability to use strictly macros like
GET_CURRENT_DIR, CHANGE_DIR, etc. in C++ class headers and #define them
with support headers? 

A quick look on the LyX-macro synopsis table (or how you would call it)
and you can configure them for your OS in a rush!

Greets,

        Arnd

Reply via email to