On Mon, 17 Aug 2026 19:58:42 GMT, Kevin Rushforth <[email protected]> wrote:
>> I am using terminology used in the `AccessibleAttribute` class. For >> example, L91 specifies the "Parameters:", whatever that is. Perhaps it >> should be renamed "Structure:" or something like that. >> >> edit: Also, we should probably drop the "Parameters:" `<li>` when it's empty. > > Parameters is consistently used in this class to mean _input_ parameters. The > example from L91 (`BOUNDS_FOR_RANGE `) are input parameters. For this new > attribute, as with many (most) others, there are none. > >> Perhaps it should be renamed "Structure:" or something like that. > > Why? Parameters is used elsewhere (e.g., for method parameters) to mean > effectively the same thing. No need to invent a new term. > >> Also, we should probably drop the "Parameters:" `<li>` when it's empty. > > Maybe, but that's tangential to this PR. I see - perhaps they should be called "Input Parameters:" then? And in case of the `VISIBLE_ITEM_RANGE` we need to document the return value structure, because `Return Type: int[]` is insufficient. ------------- PR Review Comment: https://git.openjdk.org/jfx/pull/2217#discussion_r3798637510
