LuKreme:
> On 14-Mar-2009, at 19:39, Wietse Venema wrote:
> > LuKreme:
> >> In reading <http://www.postfix.org/TLS_README.html> and all the posts
> >> in the last 15 months with 'smtpd_tls_session_cache_database' in the
> >> subject (all 7 of them!), it is not clear to me how the
> >> smtpd_tls_session_cache_database file is created, or what exactly it
> >> contains. If the file is not present, postfix doesn't create it, but
> >> logs a fatal error.
> >
> > What are:
> >
> > - the configuration
>
> # TLS
> smtpd_tls_cert_file = /etc/postfix/server.pem
> smtpd_tls_key_file = $smtpd_tls_cert_file
> smtpd_tls_loglevel = 2 # will drop to 0 or 1 after setup is complete
> smtpd_tls_security_level = may
> smtpd_tls_session_cache_database = btree:$data_directory/
> smtpd_sessions
> smtpd_tls_session_cache_timeout = 1800s # 30 minutes
> smtpd_starttls_timeout = 90s
Please stop wasting everyone's time and SHOW ACTUAL "postconf -n"
output, instead of what you believe was the configuration when you
made your mistake.
> > - the corresponding error message
>
> postfix/smtpd[67779]: fatal: open database /var/db/postfix/
> smtpd_sessions.db: No such file or directory
smtpd never uses the smtpd_tls_session_cache_database setting.
You have that file configured via some other main.cf parameter.
Wietse