Hi everyone.

There are various reasons to keep those methods around, some of which
are:

1) Follow the Principle Of Least Surprise (POLS) by exposing a similar
API across the whole platform,
2) simplify duck-typing, and
3) abstract implementation details (for example, Hash#isEmpty isn't as
trivial to write as Array#isEmpty).

Some of these methods clearly deserve to have better names. We're
going to introduce naming changes in the upcoming versions of
Prototype. Here's a tentative schedule using Array#(empty|isEmpty) as
an example:

In version 1.7:
- Array#empty is renamed Array#isEmpty.
- Array#empty, an alias of Array#isEmpty is added to source.
- Array#empty is tagged as "deprecated" and "alias of" in the
documentation.
- Array#empty is marked as deprecated in the upgrade helper.

In version 2.0:
- Array#empty is removed from source code.
- Array#empty is marked as removed in the upgrade helper.
- Array#empty is completely removed from the documentation.

It's obviously applicable to other method names.

I don't see any incentives to remove those methods altogether. If you
don't want to use them, just don't.

Thanks all for our input.

Best,

Tobie
--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"Prototype: Core" group.
To post to this group, send email to prototype-core@googlegroups.com
To unsubscribe from this group, send email to 
prototype-core-unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/prototype-core?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to