Virtual Link Problem [7:69640]

2003-05-27 Thread Kevin Love
Hey Team,

I cannot figure this out.  I've configured lots of virtual links, but no
matter what I do this isn't working.  I had md5 authentication configured
for Area 0, but to isolate the problem, I removed authentication and the
virtual link still isn't up.  I need another set of eyes (or two) looking at
this.  Please help if you can!

Here's the topology:

Area 2 (Loopback 0)
 |
 R2
   \
\
 FR
   Area 1
 /\
R5R6
 \/
   Area 0
  Ethernet

Here are the salient config snippets:

R2
!
interface Loopback0
 ip address 192.168.2.2 255.255.255.255
 ip ospf network point-to-point
!
interface Serial1.256 multipoint
 ip address 172.16.56.2 255.255.255.248
 ip ospf priority 255
 frame-relay map ip 172.16.56.2 105
 frame-relay map ip 172.16.56.5 105 broadcast
 frame-relay map ip 172.16.56.6 106 broadcast
 no frame-relay inverse-arp
!
router ospf 1
 log-adjacency-changes
 area 1 virtual-link 192.168.5.5
 area 1 virtual-link 192.168.6.6
 network 172.16.56.0 0.0.0.7 area 1
 network 192.168.2.2 0.0.0.0 area 2
!

R5

interface Ethernet0
 ip address 172.16.200.5 255.255.255.128
 ip ospf hello-interval 15
!
interface Serial0
 ip address 172.16.56.5 255.255.255.248
 encapsulation frame-relay
 ip ospf network point-to-multipoint
 frame-relay map ip 172.16.56.2 501 broadcast
 frame-relay map ip 172.16.56.5 501
 frame-relay map ip 172.16.56.6 501 broadcast
 no frame-relay inverse-arp
 frame-relay lmi-type cisco
!
router ospf 1
 log-adjacency-changes
 area 1 virtual-link 192.168.2.2
 network 172.16.56.0 0.0.0.7 area 1
 network 172.16.200.0 0.0.0.127 area 0
 network 192.168.5.5 0.0.0.0 area 5
!

R6

interface Serial0
 ip address 172.16.56.6 255.255.255.248
 encapsulation frame-relay
 ip ospf network point-to-multipoint
 frame-relay map ip 172.16.56.2 601 broadcast
 frame-relay map ip 172.16.56.5 601 broadcast
 frame-relay map ip 172.16.56.6 601
 no frame-relay inverse-arp
 frame-relay lmi-type cisco
!
interface FastEthernet0
 ip address 172.16.200.6 255.255.255.128
 ip ospf hello-interval 15
 half-duplex
!
router ospf 1
 log-adjacency-changes
 area 1 virtual-link 192.168.2.2
 network 172.16.56.0 0.0.0.7 area 1
 network 172.16.200.0 0.0.0.127 area 0
 network 192.168.6.6 0.0.0.0 area 6
!

R2#sh ip ospf vir
Virtual Link OSPF_VL5 to router 192.168.5.5 is down
  Run as demand circuit
  DoNotAge LSA allowed.
  Transit area 1, Cost of using 65535
  Transmit Delay is 1 sec, State DOWN,
  Timer intervals configured, Hello 10,  40, Wait 40, Retransmit 5
Virtual Link OSPF_VL4 to router 192.168.6.6 is down
  Run as demand circuit
  DoNotAge LSA allowed.
  Transit area 1, Cost of using 65535
  Transmit Delay is 1 sec, State DOWN,
  Timer intervals configured, Hello 10,  40, Wait 40, Retransmit 5
R2#

Trust me on the router-IDs for the virtual link statements - I have
triple-checked them.  I have reloaded the routers with no luck.  What am I
missing here?!

Thanks!
Kevin


Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=69640&t=69640
--
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]


Re: Virtual Link Problem [7:69640]

2003-05-28 Thread ian williams
I cant see a problem here, but I have been caught on this one before when
using MD5 authentication.
Remember when using MD5 authentication in Area 0 the R2 will have a direct
connection into Area 0 after the virtual link has been made
so needs to have MD5 authentication as well. You can also do MD5
authentication on the virtual link itself, this was what I was trying to do
and got confused with the MD5 authentication between R2 and Area 0.
When I removed all the MD5 authentication it still would come up. In the end
I removed the config and started again, bingo it came up


- Original Message - 
From: "Kevin Love" 
To: 
Sent: Wednesday, May 28, 2003 5:37 AM
Subject: Virtual Link Problem [7:69640]


> Hey Team,
>
> I cannot figure this out.  I've configured lots of virtual links, but no
> matter what I do this isn't working.  I had md5 authentication configured
> for Area 0, but to isolate the problem, I removed authentication and the
> virtual link still isn't up.  I need another set of eyes (or two) looking
at
> this.  Please help if you can!
>
> Here's the topology:
>
> Area 2 (Loopback 0)
>  |
>  R2
>\
> \
>  FR
>Area 1
>  /\
> R5R6
>  \/
>Area 0
>   Ethernet
>
> Here are the salient config snippets:
>
> R2
> !
> interface Loopback0
>  ip address 192.168.2.2 255.255.255.255
>  ip ospf network point-to-point
> !
> interface Serial1.256 multipoint
>  ip address 172.16.56.2 255.255.255.248
>  ip ospf priority 255
>  frame-relay map ip 172.16.56.2 105
>  frame-relay map ip 172.16.56.5 105 broadcast
>  frame-relay map ip 172.16.56.6 106 broadcast
>  no frame-relay inverse-arp
> !
> router ospf 1
>  log-adjacency-changes
>  area 1 virtual-link 192.168.5.5
>  area 1 virtual-link 192.168.6.6
>  network 172.16.56.0 0.0.0.7 area 1
>  network 192.168.2.2 0.0.0.0 area 2
> !
>
> R5
>
> interface Ethernet0
>  ip address 172.16.200.5 255.255.255.128
>  ip ospf hello-interval 15
> !
> interface Serial0
>  ip address 172.16.56.5 255.255.255.248
>  encapsulation frame-relay
>  ip ospf network point-to-multipoint
>  frame-relay map ip 172.16.56.2 501 broadcast
>  frame-relay map ip 172.16.56.5 501
>  frame-relay map ip 172.16.56.6 501 broadcast
>  no frame-relay inverse-arp
>  frame-relay lmi-type cisco
> !
> router ospf 1
>  log-adjacency-changes
>  area 1 virtual-link 192.168.2.2
>  network 172.16.56.0 0.0.0.7 area 1
>  network 172.16.200.0 0.0.0.127 area 0
>  network 192.168.5.5 0.0.0.0 area 5
> !
>
> R6
>
> interface Serial0
>  ip address 172.16.56.6 255.255.255.248
>  encapsulation frame-relay
>  ip ospf network point-to-multipoint
>  frame-relay map ip 172.16.56.2 601 broadcast
>  frame-relay map ip 172.16.56.5 601 broadcast
>  frame-relay map ip 172.16.56.6 601
>  no frame-relay inverse-arp
>  frame-relay lmi-type cisco
> !
> interface FastEthernet0
>  ip address 172.16.200.6 255.255.255.128
>  ip ospf hello-interval 15
>  half-duplex
> !
> router ospf 1
>  log-adjacency-changes
>  area 1 virtual-link 192.168.2.2
>  network 172.16.56.0 0.0.0.7 area 1
>  network 172.16.200.0 0.0.0.127 area 0
>  network 192.168.6.6 0.0.0.0 area 6
> !
>
> R2#sh ip ospf vir
> Virtual Link OSPF_VL5 to router 192.168.5.5 is down
>   Run as demand circuit
>   DoNotAge LSA allowed.
>   Transit area 1, Cost of using 65535
>   Transmit Delay is 1 sec, State DOWN,
>   Timer intervals configured, Hello 10,  40, Wait 40, Retransmit 5
> Virtual Link OSPF_VL4 to router 192.168.6.6 is down
>   Run as demand circuit
>   DoNotAge LSA allowed.
>   Transit area 1, Cost of using 65535
>   Transmit Delay is 1 sec, State DOWN,
>   Timer intervals configured, Hello 10,  40, Wait 40, Retransmit 5
> R2#
>
> Trust me on the router-IDs for the virtual link statements - I have
> triple-checked them.  I have reloaded the routers with no luck.  What am I
> missing here?!
>
> Thanks!
> Kevin




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=69653&t=69640
--
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]


RE: Virtual Link Problem [7:69640]

2003-05-28 Thread Troy Leliard
Dont really have time at the moment to look into this, but something that
you may want to investigate is the different LSA adverts sent out by
different interface types in OSPF.  Depending on the type of interface OSPF
behaves different;y, ie different HELO timers, differnet DEAD timers etc. 
You need to ensure that all neighbors within the area are using the same
type.  You can change this using the interface command ip ospf network

Full details of of various interface types and how they affect OSPF can be
found on http://www.chuckslongroad.info/OSPF_Frame_Reference.htm

Kevin Love wrote:
> 
> Hey Team,
> 
> I cannot figure this out.  I've configured lots of virtual
> links, but no matter what I do this isn't working.  I had md5
> authentication configured for Area 0, but to isolate the
> problem, I removed authentication and the virtual link still
> isn't up.  I need another set of eyes (or two) looking at
> this.  Please help if you can!
> 
> Here's the topology:
> 
> Area 2 (Loopback 0)
>  |
>  R2
>\
> \
>  FR
>Area 1
>  /\
> R5R6
>  \/
>Area 0
>   Ethernet
> 
> Here are the salient config snippets:
> 
> R2
> !
> interface Loopback0
>  ip address 192.168.2.2 255.255.255.255
>  ip ospf network point-to-point
> !
> interface Serial1.256 multipoint
>  ip address 172.16.56.2 255.255.255.248
>  ip ospf priority 255
>  frame-relay map ip 172.16.56.2 105
>  frame-relay map ip 172.16.56.5 105 broadcast
>  frame-relay map ip 172.16.56.6 106 broadcast
>  no frame-relay inverse-arp
> !
> router ospf 1
>  log-adjacency-changes
>  area 1 virtual-link 192.168.5.5
>  area 1 virtual-link 192.168.6.6
>  network 172.16.56.0 0.0.0.7 area 1
>  network 192.168.2.2 0.0.0.0 area 2
> !
> 
> R5
> 
> interface Ethernet0
>  ip address 172.16.200.5 255.255.255.128
>  ip ospf hello-interval 15
> !
> interface Serial0
>  ip address 172.16.56.5 255.255.255.248
>  encapsulation frame-relay
>  ip ospf network point-to-multipoint
>  frame-relay map ip 172.16.56.2 501 broadcast
>  frame-relay map ip 172.16.56.5 501
>  frame-relay map ip 172.16.56.6 501 broadcast
>  no frame-relay inverse-arp
>  frame-relay lmi-type cisco
> !
> router ospf 1
>  log-adjacency-changes
>  area 1 virtual-link 192.168.2.2
>  network 172.16.56.0 0.0.0.7 area 1
>  network 172.16.200.0 0.0.0.127 area 0
>  network 192.168.5.5 0.0.0.0 area 5
> !
> 
> R6
> 
> interface Serial0
>  ip address 172.16.56.6 255.255.255.248
>  encapsulation frame-relay
>  ip ospf network point-to-multipoint
>  frame-relay map ip 172.16.56.2 601 broadcast
>  frame-relay map ip 172.16.56.5 601 broadcast
>  frame-relay map ip 172.16.56.6 601
>  no frame-relay inverse-arp
>  frame-relay lmi-type cisco
> !
> interface FastEthernet0
>  ip address 172.16.200.6 255.255.255.128
>  ip ospf hello-interval 15
>  half-duplex
> !
> router ospf 1
>  log-adjacency-changes
>  area 1 virtual-link 192.168.2.2
>  network 172.16.56.0 0.0.0.7 area 1
>  network 172.16.200.0 0.0.0.127 area 0
>  network 192.168.6.6 0.0.0.0 area 6
> !
> 
> R2#sh ip ospf vir
> Virtual Link OSPF_VL5 to router 192.168.5.5 is down
>   Run as demand circuit
>   DoNotAge LSA allowed.
>   Transit area 1, Cost of using 65535
>   Transmit Delay is 1 sec, State DOWN,
>   Timer intervals configured, Hello 10,  40, Wait 40,
> Retransmit 5
> Virtual Link OSPF_VL4 to router 192.168.6.6 is down
>   Run as demand circuit
>   DoNotAge LSA allowed.
>   Transit area 1, Cost of using 65535
>   Transmit Delay is 1 sec, State DOWN,
>   Timer intervals configured, Hello 10,  40, Wait 40,
> Retransmit 5
> R2#
> 
> Trust me on the router-IDs for the virtual link statements - I
> have triple-checked them.  I have reloaded the routers with no
> luck.  What am I missing here?!
> 
> Thanks!
> Kevin


Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=69663&t=69640
--
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]


Re: Virtual Link Problem [7:69640]

2003-05-29 Thread NetChild
Hi Kevin,

can you set the default values for ospf hello interval. can you post the
result of "show ip ospf int" and "show ip ospf data" from all the three
routers.

NetChild,
""Kevin Love""  wrote in message
news:[EMAIL PROTECTED]
> Hey Team,
>
> I cannot figure this out.  I've configured lots of virtual links, but no
> matter what I do this isn't working.  I had md5 authentication configured
> for Area 0, but to isolate the problem, I removed authentication and the
> virtual link still isn't up.  I need another set of eyes (or two) looking
at
> this.  Please help if you can!
>
> Here's the topology:
>
> Area 2 (Loopback 0)
>  |
>  R2
>\
> \
>  FR
>Area 1
>  /\
> R5R6
>  \/
>Area 0
>   Ethernet
>
> Here are the salient config snippets:
>
> R2
> !
> interface Loopback0
>  ip address 192.168.2.2 255.255.255.255
>  ip ospf network point-to-point
> !
> interface Serial1.256 multipoint
>  ip address 172.16.56.2 255.255.255.248
>  ip ospf priority 255
>  frame-relay map ip 172.16.56.2 105
>  frame-relay map ip 172.16.56.5 105 broadcast
>  frame-relay map ip 172.16.56.6 106 broadcast
>  no frame-relay inverse-arp
> !
> router ospf 1
>  log-adjacency-changes
>  area 1 virtual-link 192.168.5.5
>  area 1 virtual-link 192.168.6.6
>  network 172.16.56.0 0.0.0.7 area 1
>  network 192.168.2.2 0.0.0.0 area 2
> !
>
> R5
>
> interface Ethernet0
>  ip address 172.16.200.5 255.255.255.128
>  ip ospf hello-interval 15
> !
> interface Serial0
>  ip address 172.16.56.5 255.255.255.248
>  encapsulation frame-relay
>  ip ospf network point-to-multipoint
>  frame-relay map ip 172.16.56.2 501 broadcast
>  frame-relay map ip 172.16.56.5 501
>  frame-relay map ip 172.16.56.6 501 broadcast
>  no frame-relay inverse-arp
>  frame-relay lmi-type cisco
> !
> router ospf 1
>  log-adjacency-changes
>  area 1 virtual-link 192.168.2.2
>  network 172.16.56.0 0.0.0.7 area 1
>  network 172.16.200.0 0.0.0.127 area 0
>  network 192.168.5.5 0.0.0.0 area 5
> !
>
> R6
>
> interface Serial0
>  ip address 172.16.56.6 255.255.255.248
>  encapsulation frame-relay
>  ip ospf network point-to-multipoint
>  frame-relay map ip 172.16.56.2 601 broadcast
>  frame-relay map ip 172.16.56.5 601 broadcast
>  frame-relay map ip 172.16.56.6 601
>  no frame-relay inverse-arp
>  frame-relay lmi-type cisco
> !
> interface FastEthernet0
>  ip address 172.16.200.6 255.255.255.128
>  ip ospf hello-interval 15
>  half-duplex
> !
> router ospf 1
>  log-adjacency-changes
>  area 1 virtual-link 192.168.2.2
>  network 172.16.56.0 0.0.0.7 area 1
>  network 172.16.200.0 0.0.0.127 area 0
>  network 192.168.6.6 0.0.0.0 area 6
> !
>
> R2#sh ip ospf vir
> Virtual Link OSPF_VL5 to router 192.168.5.5 is down
>   Run as demand circuit
>   DoNotAge LSA allowed.
>   Transit area 1, Cost of using 65535
>   Transmit Delay is 1 sec, State DOWN,
>   Timer intervals configured, Hello 10,  40, Wait 40, Retransmit 5
> Virtual Link OSPF_VL4 to router 192.168.6.6 is down
>   Run as demand circuit
>   DoNotAge LSA allowed.
>   Transit area 1, Cost of using 65535
>   Transmit Delay is 1 sec, State DOWN,
>   Timer intervals configured, Hello 10,  40, Wait 40, Retransmit 5
> R2#
>
> Trust me on the router-IDs for the virtual link statements - I have
> triple-checked them.  I have reloaded the routers with no luck.  What am I
> missing here?!
>
> Thanks!
> Kevin




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=69679&t=69640
--
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]


Re: Virtual Link Problem [7:69640]

2003-05-29 Thread Kevin Love
R2#sh ip ospf int
Serial1.256 is up, line protocol is up
  Internet Address 172.16.56.2/29, Area 1
  Process ID 1, Router ID 192.168.2.2, Network Type NON_BROADCAST, Cost: 64
  Transmit Delay is 1 sec, State DR, Priority 255
  Designated Router (ID) 192.168.2.2, Interface address 172.16.56.2
  Backup Designated router (ID) 192.168.6.6, Interface address 172.16.56.6
  Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
Hello due in 00:00:07
  Index 1/3, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 2, maximum is 8
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 2, Adjacent neighbor count is 2
Adjacent with neighbor 192.168.5.5
Adjacent with neighbor 192.168.6.6  (Backup Designated Router)
  Suppress hello for 0 neighbor(s)
Loopback0 is up, line protocol is up
  Internet Address 192.168.2.2/32, Area 2
  Process ID 1, Router ID 192.168.2.2, Network Type POINT_TO_POINT, Cost: 1
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
  Index 1/4, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 0, maximum is 0
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 0, Adjacent neighbor count is 0
  Suppress hello for 0 neighbor(s)
R2#sh ip ospf data

OSPF Router with ID (192.168.2.2) (Process ID 1)

Router Link States (Area 0)

Link ID ADV Router  Age Seq#   Checksum Link count
192.168.2.2 192.168.2.2 803 0x8015 0x0079D8 0

Router Link States (Area 1)

Link ID ADV Router  Age Seq#   Checksum Link count
192.168.2.2 192.168.2.2 284 0x8017 0x00A072 1
192.168.5.5 192.168.5.5 268 0x8016 0x004A3C 2
192.168.6.6 192.168.6.6 612 0x8016 0x004C34 2

Net Link States (Area 1)

Link ID ADV Router  Age Seq#   Checksum
172.16.56.2 192.168.2.2 284 0x8015 0x003C32

Summary Net Link States (Area 1)

Link ID ADV Router  Age Seq#   Checksum
172.16.56.5 192.168.6.6 11300x8014 0x00F0C8
172.16.56.6 192.168.5.5 777 0x8014 0x004E63
172.16.69.0 192.168.5.5 777 0x8014 0x006B02
172.16.69.0 192.168.6.6 613 0x8015 0x00F77C
172.16.90.128   192.168.5.5 777 0x8014 0x009A3F
172.16.90.128   192.168.6.6 613 0x8015 0x0027B9
172.16.200.0192.168.5.5 528 0x801C 0x004757
172.16.200.0192.168.6.6 875 0x801A 0x00E3C3
192.168.5.5 192.168.5.5 269 0x8015 0x00033E
192.168.5.5 192.168.6.6 11310x8014 0x00023D
192.168.6.6 192.168.5.5 777 0x8014 0x0054E1
192.168.6.6 192.168.6.6 613 0x8015 0x00E05C

Summary ASB Link States (Area 1)

Link ID ADV Router  Age Seq#   Checksum
192.168.9.9 192.168.5.5 777 0x8014 0x007F70
192.168.9.9 192.168.6.6 613 0x8015 0x000CEA

Router Link States (Area 2)

Link ID ADV Router  Age Seq#   Checksum Link count
192.168.2.2 192.168.2.2 287 0x8016 0x00854D 1

Type-5 AS External Link States

Link ID ADV Router  Age Seq#   Checksum Tag
11.4.102.4  192.168.2.2 806 0x8013 0x004F58 0
11.4.104.4  192.168.2.2 807 0x8013 0x00396C 0
172.16.10.0 192.168.2.2 546 0x8013 0x00B21A 0
172.16.12.0 192.168.2.2 546 0x8013 0x009C2E 0
172.16.24.0 192.168.2.2 807 0x8013 0x00FC52 0
192.16.40.0 192.168.2.2 807 0x8013 0x0059CE 0
192.168.9.9 192.168.9.9 464 0x8015 0x00CEC6 0
R2#


R5#sh ip ospf int
Ethernet0 is up, line protocol is up
  Internet Address 172.16.200.5/25, Area 0
  Process ID 1, Router ID 192.168.5.5, Network Type BROADCAST, Cost: 10
  Transmit Delay is 1 sec, State DROTHER, Priority 1
  Designated Router (ID) 192.168.7.7, Interface address 172.16.200.7
  Backup Designated router (ID) 192.168.6.6, Interface address 172.16.200.6
  Timer intervals configured, Hello 15, Dead 60, Wait 60, Retransmit 5
Hello due in 00:00:02
  Index 2/3, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 3, maximum is 4
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 2, Adjacent neighbor count is 2
Adjacent with neighbor 192.168.7.7  (Designated Router)
Adjacent with neighbor 192.168.6.6  (Backup Designated Router)
  Suppress hello for 0 neighbor(s)
Serial0 is up, line protocol is up
  Internet Address 172.16.56.5/29, Area 1
  Process ID 1, Router ID 192.168.5.5, Network Type POINT_TO_MULTIPOINT,
Cost: 6
4
  Transmit Delay is 1 sec, St

Re: Virtual Link Problem [7:69640]

2003-05-29 Thread Tom Martin
Kevin,

It might just be an oversight, but R5 and R6 don't seem to have a 
loopback or explicit router ID defined.

Also, what is the OSPF network type on R2?  It's set manually on R5 and 
R6, but left to the default on R2.  I believe (but haven't verified) the 
default would be non-broadcast not point-to-multipoint.

- Tom

Kevin Love wrote:
> Hey Team,
> 
> I cannot figure this out.  I've configured lots of virtual links, but no
> matter what I do this isn't working.  I had md5 authentication configured
> for Area 0, but to isolate the problem, I removed authentication and the
> virtual link still isn't up.  I need another set of eyes (or two) looking
at
> this.  Please help if you can!
> 
> Here's the topology:
> 
> Area 2 (Loopback 0)
>  |
>  R2
>\
> \
>  FR
>Area 1
>  /\
> R5R6
>  \/
>Area 0
>   Ethernet
> 
> Here are the salient config snippets:
> 
> R2
> !
> interface Loopback0
>  ip address 192.168.2.2 255.255.255.255
>  ip ospf network point-to-point
> !
> interface Serial1.256 multipoint
>  ip address 172.16.56.2 255.255.255.248
>  ip ospf priority 255
>  frame-relay map ip 172.16.56.2 105
>  frame-relay map ip 172.16.56.5 105 broadcast
>  frame-relay map ip 172.16.56.6 106 broadcast
>  no frame-relay inverse-arp
> !
> router ospf 1
>  log-adjacency-changes
>  area 1 virtual-link 192.168.5.5
>  area 1 virtual-link 192.168.6.6
>  network 172.16.56.0 0.0.0.7 area 1
>  network 192.168.2.2 0.0.0.0 area 2
> !
> 
> R5
> 
> interface Ethernet0
>  ip address 172.16.200.5 255.255.255.128
>  ip ospf hello-interval 15
> !
> interface Serial0
>  ip address 172.16.56.5 255.255.255.248
>  encapsulation frame-relay
>  ip ospf network point-to-multipoint
>  frame-relay map ip 172.16.56.2 501 broadcast
>  frame-relay map ip 172.16.56.5 501
>  frame-relay map ip 172.16.56.6 501 broadcast
>  no frame-relay inverse-arp
>  frame-relay lmi-type cisco
> !
> router ospf 1
>  log-adjacency-changes
>  area 1 virtual-link 192.168.2.2
>  network 172.16.56.0 0.0.0.7 area 1
>  network 172.16.200.0 0.0.0.127 area 0
>  network 192.168.5.5 0.0.0.0 area 5
> !
> 
> R6
> 
> interface Serial0
>  ip address 172.16.56.6 255.255.255.248
>  encapsulation frame-relay
>  ip ospf network point-to-multipoint
>  frame-relay map ip 172.16.56.2 601 broadcast
>  frame-relay map ip 172.16.56.5 601 broadcast
>  frame-relay map ip 172.16.56.6 601
>  no frame-relay inverse-arp
>  frame-relay lmi-type cisco
> !
> interface FastEthernet0
>  ip address 172.16.200.6 255.255.255.128
>  ip ospf hello-interval 15
>  half-duplex
> !
> router ospf 1
>  log-adjacency-changes
>  area 1 virtual-link 192.168.2.2
>  network 172.16.56.0 0.0.0.7 area 1
>  network 172.16.200.0 0.0.0.127 area 0
>  network 192.168.6.6 0.0.0.0 area 6
> !
> 
> R2#sh ip ospf vir
> Virtual Link OSPF_VL5 to router 192.168.5.5 is down
>   Run as demand circuit
>   DoNotAge LSA allowed.
>   Transit area 1, Cost of using 65535
>   Transmit Delay is 1 sec, State DOWN,
>   Timer intervals configured, Hello 10,  40, Wait 40, Retransmit 5
> Virtual Link OSPF_VL4 to router 192.168.6.6 is down
>   Run as demand circuit
>   DoNotAge LSA allowed.
>   Transit area 1, Cost of using 65535
>   Transmit Delay is 1 sec, State DOWN,
>   Timer intervals configured, Hello 10,  40, Wait 40, Retransmit 5
> R2#
> 
> Trust me on the router-IDs for the virtual link statements - I have
> triple-checked them.  I have reloaded the routers with no luck.  What am I
> missing here?!
> 
> Thanks!
> Kevin




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=69720&t=69640
--
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]


Re: Virtual Link Problem [7:69640]

2003-05-29 Thread Scott
Check your network types on the connections between r2 and r5 and r2 and r6.

Cheers,

Scott

""Kevin Love""  wrote in message
news:[EMAIL PROTECTED]
> R2#sh ip ospf int
> Serial1.256 is up, line protocol is up
>   Internet Address 172.16.56.2/29, Area 1
>   Process ID 1, Router ID 192.168.2.2, Network Type NON_BROADCAST, Cost:
64
>   Transmit Delay is 1 sec, State DR, Priority 255
>   Designated Router (ID) 192.168.2.2, Interface address 172.16.56.2
>   Backup Designated router (ID) 192.168.6.6, Interface address 172.16.56.6
>   Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
> Hello due in 00:00:07
>   Index 1/3, flood queue length 0
>   Next 0x0(0)/0x0(0)
>   Last flood scan length is 2, maximum is 8
>   Last flood scan time is 0 msec, maximum is 0 msec
>   Neighbor Count is 2, Adjacent neighbor count is 2
> Adjacent with neighbor 192.168.5.5
> Adjacent with neighbor 192.168.6.6  (Backup Designated Router)
>   Suppress hello for 0 neighbor(s)
> Loopback0 is up, line protocol is up
>   Internet Address 192.168.2.2/32, Area 2
>   Process ID 1, Router ID 192.168.2.2, Network Type POINT_TO_POINT, Cost:
1
>   Transmit Delay is 1 sec, State POINT_TO_POINT,
>   Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
>   Index 1/4, flood queue length 0
>   Next 0x0(0)/0x0(0)
>   Last flood scan length is 0, maximum is 0
>   Last flood scan time is 0 msec, maximum is 0 msec
>   Neighbor Count is 0, Adjacent neighbor count is 0
>   Suppress hello for 0 neighbor(s)
> R2#sh ip ospf data
>
> OSPF Router with ID (192.168.2.2) (Process ID 1)
>
> Router Link States (Area 0)
>
> Link ID ADV Router  Age Seq#   Checksum Link count
> 192.168.2.2 192.168.2.2 803 0x8015 0x0079D8 0
>
> Router Link States (Area 1)
>
> Link ID ADV Router  Age Seq#   Checksum Link count
> 192.168.2.2 192.168.2.2 284 0x8017 0x00A072 1
> 192.168.5.5 192.168.5.5 268 0x8016 0x004A3C 2
> 192.168.6.6 192.168.6.6 612 0x8016 0x004C34 2
>
> Net Link States (Area 1)
>
> Link ID ADV Router  Age Seq#   Checksum
> 172.16.56.2 192.168.2.2 284 0x8015 0x003C32
>
> Summary Net Link States (Area 1)
>
> Link ID ADV Router  Age Seq#   Checksum
> 172.16.56.5 192.168.6.6 11300x8014 0x00F0C8
> 172.16.56.6 192.168.5.5 777 0x8014 0x004E63
> 172.16.69.0 192.168.5.5 777 0x8014 0x006B02
> 172.16.69.0 192.168.6.6 613 0x8015 0x00F77C
> 172.16.90.128   192.168.5.5 777 0x8014 0x009A3F
> 172.16.90.128   192.168.6.6 613 0x8015 0x0027B9
> 172.16.200.0192.168.5.5 528 0x801C 0x004757
> 172.16.200.0192.168.6.6 875 0x801A 0x00E3C3
> 192.168.5.5 192.168.5.5 269 0x8015 0x00033E
> 192.168.5.5 192.168.6.6 11310x8014 0x00023D
> 192.168.6.6 192.168.5.5 777 0x8014 0x0054E1
> 192.168.6.6 192.168.6.6 613 0x8015 0x00E05C
>
> Summary ASB Link States (Area 1)
>
> Link ID ADV Router  Age Seq#   Checksum
> 192.168.9.9 192.168.5.5 777 0x8014 0x007F70
> 192.168.9.9 192.168.6.6 613 0x8015 0x000CEA
>
> Router Link States (Area 2)
>
> Link ID ADV Router  Age Seq#   Checksum Link count
> 192.168.2.2 192.168.2.2 287 0x8016 0x00854D 1
>
> Type-5 AS External Link States
>
> Link ID ADV Router  Age Seq#   Checksum Tag
> 11.4.102.4  192.168.2.2 806 0x8013 0x004F58 0
> 11.4.104.4  192.168.2.2 807 0x8013 0x00396C 0
> 172.16.10.0 192.168.2.2 546 0x8013 0x00B21A 0
> 172.16.12.0 192.168.2.2 546 0x8013 0x009C2E 0
> 172.16.24.0 192.168.2.2 807 0x8013 0x00FC52 0
> 192.16.40.0 192.168.2.2 807 0x8013 0x0059CE 0
> 192.168.9.9 192.168.9.9 464 0x8015 0x00CEC6 0
> R2#
>
>
> R5#sh ip ospf int
> Ethernet0 is up, line protocol is up
>   Internet Address 172.16.200.5/25, Area 0
>   Process ID 1, Router ID 192.168.5.5, Network Type BROADCAST, Cost: 10
>   Transmit Delay is 1 sec, State DROTHER, Priority 1
>   Designated Router (ID) 192.168.7.7, Interface address 172.16.200.7
>   Backup Designated router (ID) 192.168.6.6, Interface address
172.16.200.6
>   Timer intervals configured, Hello 15, Dead 60, Wait 60, Retransmit 5
> Hello due in 00:00:02
>   Index 2/3, flood queue length 0
>   Next 0x0(0)/0x0(0)
>   Last flood scan length is 3, maximum is 4
>   Last flood scan time is 0 msec, maximum is 0 msec
>   Neighbor Count is 2, Adjacent neighbor count is 2
> Adjace

Re: Virtual Link Problem [7:69640]

2003-05-29 Thread Kevin Love
Tom,

Congratulations, it appears that you hit the nail right on the head.  Router
ID was not an issue - I just failed to show you the loopback interfaces. 
The issue was apparently network type.  As soon as I hard-set R2s network
type to point-to-multipoint (it was, as you correctly pointed out,
non-broadcast by default), the virtual link came up.  What I now don't
understand is why I had a full neighbor relationship before I changed the
network type.  Shouldn't the mismatch have caused my neighbor relationship
to be affected?

Thanks for the tip!
Kevin


Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=69730&t=69640
--
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]


Re: Virtual Link Problem [7:69640]

2003-05-30 Thread NetChild
Hi,

Congratulation that you solve it out.

> network type.  Shouldn't the mismatch have caused my neighbor relationship
> to be affected?

Since OPSF network type was non-broadcast network, the hello interval is 30
second and the dead interval is 120. These interval times match the
point-to-multipoint and this meet the need to form neighboring relationship.
However, these will not help to run OSPF correctly. The behavior of
non-broadcast is different that point-to-multipoint. Example, From the
result of "show ip ospf int" The network was nonbroadcast and there is BDR.
In point-to-multipoint there is no DR/BDR.

Please correct me if I'm wrong,

Netchild,
""Kevin Love""  wrote in message
news:[EMAIL PROTECTED]
> Tom,
>
> Congratulations, it appears that you hit the nail right on the head.
Router
> ID was not an issue - I just failed to show you the loopback interfaces.
> The issue was apparently network type.  As soon as I hard-set R2s network
> type to point-to-multipoint (it was, as you correctly pointed out,
> non-broadcast by default), the virtual link came up.  What I now don't
> understand is why I had a full neighbor relationship before I changed the
> network type.  Shouldn't the mismatch have caused my neighbor relationship
> to be affected?
>
> Thanks for the tip!
> Kevin




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=69766&t=69640
--
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]