On Jun 4, 2007, at 9:56 AM, Rick Morrison wrote:

> The use of scalar() here seems out of place with both the common CS  
> usage of the word (e.g. scalar == single-valued), and the use of  
> scalar() in the SQL layer. Single row results in the ORM are rows,  
> not a single datatype. It's another potential point of confusion,  
> like the ORM .select() is/was.
>
> I would say drop scalar() in the ORM namespace, and for single-row  
> results, use
>
> .first() -- returns first row
> .one() -- returns first row, raise exception if more than one result
>
>

then we sort of have to rename list() to be all().

its all fine with me if everyone out there doesnt mind changing their  
code by the time 0.5 comes out....


--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"sqlalchemy" group.
To post to this group, send email to sqlalchemy@googlegroups.com
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at 
http://groups.google.com/group/sqlalchemy?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to