Hi!

> giving the ng_stack a name sounds like a very good idea to me (and as far as
> I remembered I already mentioned this last summer...). Though finding a name
> is tough and I don't like the obvious once (flexnet_, default_, riotnet_,
> etc...).

To make it easier, I think we can even discard the name prefix. It's very
unlikely that we want to have to have two IPv6 implementations running
parallel. So, assume we have `default_stack` and `tiny_stack`, it's fine if
both define `ipv6_send()` instead of `default_ipv6_send()`.

> Also 'cutting' out the re-usable parts as headers, header parsing, checksum
> calculation and some others might make sense, though with this I think we
> have to keep in mind, that not every network stack implementation has to use
> those 'generic' building blocks, as these implementations might have their
> own requirements to certain function signatures etc...

Sure, that remains to be seen, but I think for some basic functionalities it
might be possible.
 
> When it comes to protocol header files, as 'net/udp.h', I would be even more
> careful. I don't think we will have a generic udp header, that each network
> stack will comply to. In my opinion, each network stack should just define
> it's own header files, as these will differ depending on their internal
> implementation...

Things like protocol headers will be exactly the same for every implementation
of this protocol, so cutting these out is a MUST. Everything implementation
specific should, of course, stay in separate headers.

Cheers,
Oleg
-- 
printk(KERN_ERR "ide: huh? queue was plugged!\n");
        linux-2.6.6/drivers/ide/ide-io.c:

Attachment: pgpY7FFKaG7Xj.pgp
Description: PGP signature

_______________________________________________
devel mailing list
devel@riot-os.org
https://lists.riot-os.org/mailman/listinfo/devel

Reply via email to