> I propose a common nomenclature.

I never like reverse Hungarian notation and variants because invariably you
end up with names that don't describe the datatype well, or you end up with
long names, and I hate long names.

I think names should be functional: "state" describes the thing without
describing the datatype, as does "event", regardless of the implementation.

>   on_stupid => Undecided::Cb::Chain->new(
>     Undecided::Cb->new(\&callback),
>     Undecided::Ob->new($object, "method"),
>     Undecided::Cl->new($class, "method"),
>     Undecided::Ev->new("event"),  # probably only valid as the last item
>   ),

not that the above couldn't equally be expressed as:

        on_stupid => [
                "event",
                \&callback,
                [$object => "method"],
                [$class, "method"]
                ];

which I find more concise and perlish.  yes, the Undecided thing helps hide
behind objects but it just seems so unwieldy.

- ekkis

http://www.arix.com/ec

Reply via email to