Wishful reading...
Are you always this condescending or it's a particularly bad day and you are reserving a worse-than-usual treatment to an unknown stranger to vent it out? If that's the latter just let me know I can get by tomorrow. Or you can close your email client for the day and avoid treating other people badly just because they asked.

Either there's no map entry at all, or the map entry does not list the
SASL name.
If there is no map entry at all the mail is rejected, if the map entry does not list the SASL username that's equal to the MAIL FROM: command the email is rejected (hence the need for the third "regexp" list in my setup). The behavior still does not explain the man page statement "Reject the request when the client is authenticated with SASL, but [...] the SASL login name is not an owner for that address." because that's not what happens.

On 30/09/26 11:43, Viktor Dukhovni via Postfix-users wrote:
On Wed, Sep 30, 2026 at 11:27:23AM +0200, Luca Cavana via Postfix-users wrote:

Ok, can you help me in understanding the man page better?
Wishful reading...

reject_authenticated_sender_login_mismatch
     Reject the request when the client is authenticated with SASL, but
either the MAIL FROM address is not listed in $smtpd_sender_login_maps, or
the SASL login name is not an owner for that address.
The only meaning of "owner" that's possible here is "listed as an owner".
Either there's no map entry at all, or the map entry does not list the
SASL name.


_______________________________________________
Postfix-users mailing list -- [email protected]
To unsubscribe send an email to [email protected]

Reply via email to