On 30.09.26 11:27, Luca Cavana via Postfix-users wrote:
... because what I read from "but either the MAIL FROM address is not
listed in $smtpd_sender_login_maps, or the SASL login name is not an
owner for that address" is "but either the MAIL FROM address is not
listed in $smtpd_sender_login_maps, or the SASL login name is not
equal to that address".
What does "is not an owner of" implies that I'm missing?
the "owner of mail address" is defined in smtp_sender_login_maps:
"Optional lookup table with the SASL login names that own the envelope sender (MAIL FROM)
addresses."
Either there's no map entry at all, or the map entry does not list the
SASL name.
On 30.09.26 12:01, Luca Cavana via Postfix-users wrote:
If there is no map entry at all the mail is rejected, if the map entry
does not list the SASL username that's equal to the MAIL FROM: command
the email is rejected (hence the need for the third "regexp" list in
my setup).
the regexp is just shortcut so every address is owned by the login name
same as the address.
The behavior still does not explain the man page statement "Reject the
request when the client is authenticated with SASL, but [...] the SASL
login name is not an owner for that address." because that's not what
happens.
According to your former mail, that's exactly what happens:
NOQUEUE: reject: RCPT from unknown[2001:67c:d68:13::e]: 553 5.7.1
<[email protected]>: Sender address rejected: not owned by user
[email protected]; from=<[email protected]>
to=<redacted> proto=ESMTP helo=<[IPV6:2001:67c:d68:13::e]>
this happened when you removed the regexp.
--
Matus UHLAR - fantomas, [email protected] ; http://www.fantomas.sk/
Warning: I wish NOT to receive e-mail advertising to this address.
Varovanie: na tuto adresu chcem NEDOSTAVAT akukolvek reklamnu postu.
One OS to rule them all, One OS to find them,
One OS to bring them all and into darkness bind them
_______________________________________________
Postfix-users mailing list -- [email protected]
To unsubscribe send an email to [email protected]