Re: RFR: 8004518 & 8010122 : Default methods on Map

2013-04-11 Thread Peter Levart
On 04/11/2013 07:42 AM, Mike Duigou wrote: I've posted an updated webrev with the review comments I have received. http://cr.openjdk.java.net/~mduigou/JDK-8010122/1/webrev/ One important point to consider: - The current implementations of compute, computeIfPresent, computeIfAbsent, merge are

Re: RFR: Project files for Solaris Studio / NetBeans

2013-04-11 Thread Vladimir Voskresensky - Oracle
Hi Jesper, Just interested in the progress with review/push :-) Any news? Thanks, Vladimir. On 04/ 1/13 08:10 PM, Vladimir Voskresensky - Oracle wrote: Jesper, Minor comment: it's better to have env variable named IDE_ALT_BOOTDIR instead of IDE_JAVAPATH to give analogy with the old well know

Re: RFR: 8004518 & 8010122 : Default methods on Map

2013-04-11 Thread Ulf Zibis
Am 11.04.2013 05:20, schrieb Mike Duigou: On Apr 8 2013, at 17:08 , Ulf Zibis wrote: Why you use both, {@code...} and ... ? legacy. We're trying to use {@code } in new work but only convert existing when it's convenient. The main reason for not doing a global replacement is that we all value

Re: RFR: 8004518 & 8010122 : Default methods on Map

2013-04-11 Thread Ulf Zibis
Am 11.04.2013 08:23, schrieb Peter Levart: Hi Mike, I find IDEA's feature very useful. It can reformat just the selection, not touching anything else. NetBeans IDE too :-) -Ulf

Re: RFR 8011805: Update sun.tools.java class file reading/writing support to include the new constant pool entries (including invokedynamic)

2013-04-11 Thread Alan Bateman
On 11/04/2013 05:24, Robert Field wrote: Currently blocking lambda library pushes. Internal class reader used by rmic does not support new constant pool constant types: CONSTANT_METHODHANDLE = 15; CONSTANT_METHODTYPE = 16; CONSTANT_INVOKEDYNAMIC= 18; Pleas

Re: RFR: Project files for Solaris Studio / NetBeans

2013-04-11 Thread Dmitry Samersoff
Jesper, Is it correct that this this project is for native part of JDK only? If yes - is it possible to rename it to OpenJDK_Native or create common/netbeans/native/OpenJDK to avoid any misunderstanding and future name conflicts? I hope sometimes OpenJDK_java project appears as well. -Dmitry O

Re: RFR: Project files for Solaris Studio / NetBeans

2013-04-11 Thread Vladimir Voskresensky
Dmitry, On 04/11/2013 04:23 PM, Dmitry Samersoff wrote: Jesper, Is it correct that this this project is for native part of JDK only? Yes, it is project around C/C++ part of OpenJDK, but it's build command creates full jdk image (i.e. with all java parts as well): ${MAKE} -f Makefile LOG=debug

Re: RFR JDK-8011200 (was 7143928) : (coll) Optimize for Empty ArrayList and HashMap

2013-04-11 Thread Alan Bateman
On 10/04/2013 19:12, Mike Duigou wrote: On Apr 9 2013, at 19:56 , Martin Buchholz wrote: Mike, thanks. I don't see anything wrong in this version, although the ongoing complexification and special-case-ification (with attendant risk of bugs) of ArrayList and HashMap, the two most didacticall

Re: [OpenJDK 2D-Dev] AAShapePipe concurrency & memory waste

2013-04-11 Thread Laurent Bourgès
Jim and Sergey, 1/ Here are few benchmarks (based on mapBench again) running several modified versions of AAShapePipe: http://jmmc.fr/~bourgesl/share/AAShapePipe/mapBench/ - ref: 1 threads and 20 loops per thread, time: 3742 ms 2 threads and 20 loops per thread, time: 4756 ms 4 threads and 20 loop

Re: RFR-8008118

2013-04-11 Thread Alan Bateman
On 10/04/2013 19:14, Martin Buchholz wrote: I am happy with the latest webrev - ship it! Thanks, John! I agree, new version is so much better. Chris - are you sponsoring this one? -Alan.

Fwd: sun.awt.X11 logs still using String + (waste)

2013-04-11 Thread Laurent Bourgès
Anthony, Mandy, here the 4th patch: http://jmmc.fr/~bourgesl/share/webrev-8010297.4/ It only contains awt / swing / net classes that use PlatformLogger (no code modification). Laurent

Re: RFR-8008118

2013-04-11 Thread Chris Hegarty
On 04/11/2013 02:14 PM, Alan Bateman wrote: On 10/04/2013 19:14, Martin Buchholz wrote: I am happy with the latest webrev - ship it! Thanks, John! I agree, new version is so much better. Chris - are you sponsoring this one? -Alan. In the quite lengthly discussion for this issue we seem

Re: [OpenJDK 2D-Dev] AAShapePipe concurrency & memory waste

2013-04-11 Thread Laurent Bourgès
Last idea: I will enhance Andrea's mapBench benchmark to have statistics per threads: number of loops, avg, min, max, stddev; I guess that the total bench time is not so representative as the thread pool can distribute the work load differently at each test => statistics will help to have better t

Re: Add getChars to CharSequence

2013-04-11 Thread Alan Bateman
On 11/04/2013 01:40, Martin Buchholz wrote: I've often wished that CharSequence had getChars methods, as many of the concrete implementations already do. In jdk8 with default methods, this is possible! This will make some of the String code a little nicer and more efficient. Here's a preliminar

Re: sun.awt.X11 logs still using String + (waste)

2013-04-11 Thread Mandy Chung
Laurent, On 4/11/13 6:19 AM, Laurent Bourgès wrote: Anthony, Mandy, here the 4th patch: http://jmmc.fr/~bourgesl/share/webrev-8010297.4/ Thanks for addressing the memory overhead concern and keeping this fix for clients of PlatformLogger. Looks good and I saw that you caught several existin

Re: RFR JDK-8011200 (was 7143928) : (coll) Optimize for Empty ArrayList and HashMap

2013-04-11 Thread Mike Duigou
On Apr 11 2013, at 06:03 , Alan Bateman wrote: > On 10/04/2013 19:12, Mike Duigou wrote: >> On Apr 9 2013, at 19:56 , Martin Buchholz wrote: >> >>> Mike, thanks. >>> >>> I don't see anything wrong in this version, although the ongoing >>> complexification and special-case-ification (with atten

Re: sun.awt.X11 logs still using String + (waste)

2013-04-11 Thread Laurent Bourgès
Mandy, I'd really like to see if we can avoid the boilerplate "if (isLoggable(...)) logger.fine()" and help ease of development and I file a RFE (8012006). Agreed but there is no easy way to have clear code and performance: - maybe JDK 8 Supplier may help - or a shorter syntax: logger.isDebug

Re: sun.awt.X11 logs still using String + (waste)

2013-04-11 Thread Mandy Chung
On 4/11/13 8:43 AM, Laurent Bourgès wrote: I don't understand if I should fix it or not ? src/solaris/classes/sun/awt/X11/XListPeer.java Nit: line 1906 you remove isLoggable call here. Was it intentional (as it doesn't call concatenate any string?)? I think it's better to use

Re: RFR-8008118

2013-04-11 Thread Martin Buchholz
Agreed. When I worked on this, I was only looking at the more difficult one. The NULL check for errmsg should be merged back in. On Thu, Apr 11, 2013 at 6:28 AM, Chris Hegarty wrote: > On 04/11/2013 02:14 PM, Alan Bateman wrote: > >> On 10/04/2013 19:14, Martin Buchholz wrote: >> >>> I am happ

Re: sun.awt.X11 logs still using String + (waste)

2013-04-11 Thread Laurent Bourgès
Anthony, Here is the updated webrev: http://jmmc.fr/~bourgesl/share/webrev-8010297.5/ Laurent 2013/4/11 Mandy Chung > On 4/11/13 8:43 AM, Laurent Bourgès wrote: > > > I don't understand if I should fix it or not ? > > src/solaris/classes/sun/awt/X11/XListPeer.java >> Nit: line 1906 you rem

Re: sun.awt.X11 logs still using String + (waste)

2013-04-11 Thread Mandy Chung
On 4/11/13 9:08 AM, Laurent Bourgès wrote: Anthony, Here is the updated webrev: http://jmmc.fr/~bourgesl/share/webrev-8010297.5/ Great. Ship it! Mandy Laurent 2013/4/11 Mandy Chung > On 4/11/13 8:4

Re: RFR-8008118

2013-04-11 Thread Chris Hegarty
On 04/11/2013 05:00 PM, Martin Buchholz wrote: Agreed. When I worked on this, I was only looking at the more difficult one. The NULL check for errmsg should be merged back in. John, If you merge back in this small change, then I can sponsor the change into jdk8/tl/jdk for you. Please also

Re: sun.awt.X11 logs still using String + (waste)

2013-04-11 Thread Sergey Bylokhov
Hello. New version looks fine to me. On 4/11/13 8:08 PM, Laurent Bourgès wrote: Anthony, Here is the updated webrev: http://jmmc.fr/~bourgesl/share/webrev-8010297.5/ Laurent 2013/4/11 Mandy Chung On 4/11/13 8:43 AM, Laurent Bourgès wrote: I don't understand if I should fix it or not ?

Re: Add getChars to CharSequence

2013-04-11 Thread Martin Buchholz
On Thu, Apr 11, 2013 at 6:36 AM, Alan Bateman wrote: > On 11/04/2013 01:40, Martin Buchholz wrote: > >> I've often wished that CharSequence had getChars methods, as many of the >> concrete implementations already do. >> In jdk8 with default methods, this is possible! >> This will make some of the

Re: RFR: Project files for Solaris Studio / NetBeans

2013-04-11 Thread Ulf Zibis
Am 11.04.2013 15:00, schrieb Vladimir Voskresensky: If yes - is it possible to rename it to OpenJDK_Native or create common/netbeans/native/OpenJDK to avoid any misunderstanding and future name conflicts? what about simpler layout: common/native_project (or make/native_project) otherwise develop

Re: Add getChars to CharSequence

2013-04-11 Thread Ulf Zibis
Hi Martin, great idea! Regarding the exception handling... You should reuse getCharsOutOfBounds() from AbstractStringBuilder in String. Also IMO the exception messages need some "corporate design"; e.g. in some cases the string "srcBegin > srcEnd" is returned, in other cases the int value of s

Re: RFR: 8004518 & 8010122 : Default methods on Map

2013-04-11 Thread Mike Duigou
Another revision incorporating primarily documentation feedback. http://cr.openjdk.java.net/~mduigou/JDK-8010122/2/webrev/ I've also included the java.util.Collections overrides for the default methods. All of these are performance enhancements--the semantics were already correct because the de

Re: Add getChars to CharSequence

2013-04-11 Thread Martin Buchholz
Alan, please file an rfe for us: Add default methods CharSequence.getChars to match String and StringBuilder. Ulf et al: The exception messages for out of bounds checks are maddeningly inconsistent. Are y'all OK with making them consistent and maximally informative? something like "start = %d, e

Re: Add getChars to CharSequence

2013-04-11 Thread Alan Bateman
On 11/04/2013 18:14, Martin Buchholz wrote: : I thought about this a bit. getChars should be consistent with charAt, which does not move position and is relative to position. This is probably right although I think we'll need the spec overridden in CharBuffer to make this clear. You might be

Re: Add getChars to CharSequence

2013-04-11 Thread Alan Bateman
On 11/04/2013 21:37, Martin Buchholz wrote: Alan, please file an rfe for us: Add default methods CharSequence.getChars to match String and StringBuilder. There are several to choose from, here's one of the long longing requests: 6813523: (str) Add method CharSequence.getChars() as StringBuilde

Codereview Request: 8011647: Add java.time.Instant methods to java.nio.file.attribute.FileTime

2013-04-11 Thread Xueming Shen
Hi As part of the JSR310 Date/Time project, following methods are proposed to be added into java.nio.file.attribute.FileTime to interoperate with the new JSR310 time class Instant. public static FileTime from(Instant instant); public Instant toInstant(); http://cr.openjdk.java.net/~sherman/8011

Re: Throwable.addSuppressed error conditions -- use the exception as the cause?

2013-04-11 Thread Joe Darcy
Hello, I've filed 8012044: Give more information about self-suppression from Throwable.addSuppressed for this issue; it should be viewable on bugs.sun.com within a day or so. Cheers, -Joe On 04/08/2013 04:54 PM, Steven Schlansker wrote: Today I encountered "java.lang.IllegalArgume

Re: Add getChars to CharSequence

2013-04-11 Thread Martin Buchholz
On Thu, Apr 11, 2013 at 1:47 PM, Alan Bateman wrote: > On 11/04/2013 18:14, Martin Buchholz wrote: > >> >> : >> >> I thought about this a bit. getChars should be consistent with charAt, >> which does not move position and is relative to position. >> > This is probably right although I think we'll

Re: Add getChars to CharSequence

2013-04-11 Thread Martin Buchholz
On Thu, Apr 11, 2013 at 12:55 PM, Ulf Zibis wrote: > > Anyway as those methods all need some CPU time to execute normally, I'm > not sure if it's worth to save 1 comparison by outsourcing. > Saving one comparison is worth doing in any case in these performance-critical methods. "Out-lining" the

Re: RFR 8011805: Update sun.tools.java class file reading/writing support to include the new constant pool entries (including invokedynamic)

2013-04-11 Thread Robert Field
Thank you Mike, Alan, and Brian for your reviews, and others for your assistance. Updated webrev: http://cr.openjdk.java.net/~rfield/8011805_2 Changes are all in the test: * Removed unused testWrite and related code. * Used correct copyright. * Added finally clauses which close file and c

Re: [OpenJDK 2D-Dev] AAShapePipe concurrency & memory waste

2013-04-11 Thread Jim Graham
Hi Laurent, Yes, these kinds of minor optimizations (i.e. optimizations that don't make a clear 2x type of savings) can be frustrating at times. It looks like there is potential for a decent return there if we can find the right change. Sometimes rearranging a couple of things that don't loo

Re: RFR 8011805: Update sun.tools.java class file reading/writing support to include the new constant pool entries (including invokedynamic)

2013-04-11 Thread Remi Forax
On 04/11/2013 11:23 PM, Robert Field wrote: Thank you Mike, Alan, and Brian for your reviews, and others for your assistance. Updated webrev: http://cr.openjdk.java.net/~rfield/8011805_2 Changes are all in the test: * Removed unused testWrite and related code. * Used correct copyright.

Re: RFR JDK-8011200 (was 7143928) : (coll) Optimize for Empty ArrayList and HashMap

2013-04-11 Thread Remi Forax
On 04/11/2013 01:33 AM, Vitaly Davidovich wrote: The null check jumps should be taken care of by branch prediction; as long as they're predictable, penalty on OOO CPU is minimal. So modern CPUs don't like mispredicted branches I'd say, not just any jump. yes :) Rémi On Apr 10, 2013 7:23

Re: RFR: 8004518 & 8010122 : Default methods on Map

2013-04-11 Thread Ulf Zibis
Am 11.04.2013 22:03, schrieb Mike Duigou: Another revision incorporating primarily documentation feedback. http://cr.openjdk.java.net/~mduigou/JDK-8010122/2/webrev/ There is still a yoda style in ConcurrentMap line 72, HashMap line 361 To be in line with old habits, please remove space after

RFR: String.join(), StringJoiner additions

2013-04-11 Thread Jim Gish
Please review http://cr.openjdk.java.net/~jgish/Bugs-5015163-7175206-7172553/ These are changes that we made in lambda that we're now bringing into JDK8. I've made a couple of additions - making StringJoiner final and adding a

Re: Review request for 7198429: need checked categorization of caller-sensitive methods in the JDK

2013-04-11 Thread John Rose
On Apr 3, 2013, at 11:00 PM, Jeroen Frijters wrote: > Given the ability to create constructorless subclasses, it really should be > combined with making the class final. > > My current rules for @CallerID (which unlike @CallerSensitive is not just > about semantics, but also about implementati

Code review request for 8012044: Give more information about self-suppression from Throwable.addSuppressed

2013-04-11 Thread Joe Darcy
Hello, Please review the patch below to address 8012044: Give more information about self-suppression from Throwable.addSuppressed http://cr.openjdk.java.net/~darcy/8012044.0/ Thanks, -Joe diff -r 006a7a576fe9 src/share/classes/java/lang/Throwable.java --- a/src/share/classes/java/l

hg: jdk8/tl/langtools: 2 new changesets

2013-04-11 Thread lana . steuck
Changeset: 2c9acb17f41a Author:katleman Date: 2013-04-11 09:40 -0700 URL: http://hg.openjdk.java.net/jdk8/tl/langtools/rev/2c9acb17f41a Added tag jdk8-b85 for changeset 4a48f3173534 ! .hgtags Changeset: d13af7751456 Author:lana Date: 2013-04-11 19:15 -0700 URL: http

hg: jdk8/tl/jdk: 5 new changesets

2013-04-11 Thread lana . steuck
Changeset: e22961ea91bd Author:erikj Date: 2013-04-05 09:39 +0200 URL: http://hg.openjdk.java.net/jdk8/tl/jdk/rev/e22961ea91bd 8008373: JFR JTReg tests fail with CompilationError on MacOSX; missing '._sunec.jar' Reviewed-by: tbell ! makefiles/CompileDemos.gmk ! makefiles/CompileJa

hg: jdk8/tl/jaxws: 2 new changesets

2013-04-11 Thread lana . steuck
Changeset: 26c840af7720 Author:katleman Date: 2013-04-11 09:40 -0700 URL: http://hg.openjdk.java.net/jdk8/tl/jaxws/rev/26c840af7720 Added tag jdk8-b85 for changeset 8c0b6bccfe47 ! .hgtags Changeset: 28886cb008bb Author:lana Date: 2013-04-11 19:15 -0700 URL: http://h

hg: jdk8/tl/hotspot: 62 new changesets

2013-04-11 Thread lana . steuck
Changeset: d26674db4d91 Author:amurillo Date: 2013-03-28 19:13 -0700 URL: http://hg.openjdk.java.net/jdk8/tl/hotspot/rev/d26674db4d91 8011022: new hotspot build - hs25-b26 Reviewed-by: jcoomes ! make/hotspot_version Changeset: 0c3ee6f1fa23 Author:coleenp Date: 2013-03-27

hg: jdk8/tl: 10 new changesets

2013-04-11 Thread lana . steuck
Changeset: 52d1b385a4ed Author:erikj Date: 2013-04-04 09:24 +0200 URL: http://hg.openjdk.java.net/jdk8/tl/rev/52d1b385a4ed 8006828: "SKIP_BOOT_CYCLE=false" must work in new building infrastructure Reviewed-by: tbell, alanb ! common/autoconf/bootcycle-spec.gmk.in ! common/autoconf/s

Re: Code review request for 8012044: Give more information about self-suppression from Throwable.addSuppressed

2013-04-11 Thread Zhong Yu
It doesn't feel very right to say the exception is the "cause" of the IAE. If the user code reuses an exception instance "x", as reported by OP, there is a possibility that the IAE is later added as a suppressed exception to "x", forming a loop x->IAE->x. Zhong Yu On Thu, Apr 11, 2013 at 8:19 P

Re: Throwable.addSuppressed error conditions -- use the exception as the cause?

2013-04-11 Thread Zhong Yu
On Tue, Apr 9, 2013 at 11:54 AM, Steven Schlansker wrote: > > On Apr 9, 2013, at 9:30 AM, Zhong Yu wrote: > >> >> >> >> On Mon, Apr 8, 2013 at 6:54 PM, Steven Schlansker >> wrote: >> Today I encountered "java.lang.IllegalArgumentException: Self-suppression >> not permitted" from Throwable.addS

Re: [threeten-dev] ReviewRequest 8011172: JSR 310: DateTime API Updates II,

2013-04-11 Thread Xueming Shen
David, webrev has been updated to removed the tzdb.dat from the CreateJars.gmk as suggested. http://cr.openjdk.java.net/~sherman/8011172/webrev/ Thanks! -Sherman On 04/09/2013 08:08 AM, Xueming Shen wrote: On 4/9/13 5:00 AM, David Holmes wrote: I find it troubling the tzdb.jar is now tzdb.d

Re: [threeten-dev] ReviewRequest 8011172: JSR 310: DateTime API Updates II,

2013-04-11 Thread David Holmes
Hi Sherman, On 12/04/2013 3:46 PM, Xueming Shen wrote: David, webrev has been updated to removed the tzdb.dat from the CreateJars.gmk as suggested. http://cr.openjdk.java.net/~sherman/8011172/webrev/ In profile-includes.txt this change is wrong: ** 77,88 security/blacklist \

Re: [threeten-dev] ReviewRequest 8011172: JSR 310: DateTime API Updates II,

2013-04-11 Thread Xueming Shen
Good catch. webrev updated. It appears none of the tests catched this error, if I just build the jdk normally (?), either local fresh new build and jprt job. http://cr.openjdk.java.net/~sherman/8011172/webrev/ -Sherman. On 4/11/13 10:57 PM, David Holmes wrote: Hi Sherman, On 12/04/2013 3:46